[package] update libdmapsharing to 2.1.2 (#7894)
[openwrt/svn-archive/archive.git] / utils / bluez-utils / Makefile
index ec4f49e849d3a4a602c2a65996a7d69ea8839896..17d4f41a1b11dee212723922095018657586a2ee 100644 (file)
@@ -1,21 +1,22 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
 PKG_VERSION:=3.36
-PKG_RELEASE:=1
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
 PKG_MD5SUM:=4fc292b635ba7b442c7aaf5680199012
 
+PKG_FIXUP:=libtool
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bluez-utils
@@ -33,6 +34,7 @@ define Package/bluez-utils/conffiles
 endef
 
 CONFIGURE_ARGS += \
+       --disable-glib \
        --enable-pand \
        --enable-rfcomm \
        --enable-dund \
@@ -46,7 +48,7 @@ CONFIGURE_ARGS += \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib \
+               LDFLAGS="$(TARGET_LDFLAGS) \
                        -L$(STAGING_DIR)/usr/lib/libintl/lib \
                        -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -66,6 +68,7 @@ define Package/bluez-utils/install
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
        $(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
+       $(INSTALL_DATA) ./files/bluetooth.dbus $(1)/etc/dbus-1/system.d/bluetooth.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/bluez-utils.init $(1)/etc/init.d/bluez-utils
 endef