[packages] i2c-tools: update to svn r6199
[openwrt/svn-archive/archive.git] / utils / bluez-utils / Makefile
index 3ba38d6852e95a2a5a1e8c7aadf69733dce16407..4f3f7877f0781c6e652099ca36c4a9c3083eebbb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,18 +9,21 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
 PKG_VERSION:=3.36
-PKG_RELEASE:=6
+PKG_RELEASE:=12
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
 PKG_MD5SUM:=4fc292b635ba7b442c7aaf5680199012
 
+PKG_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/bluez-utils
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+bluez-libs +libpthread +dbus +libintl +libiconv
+  DEPENDS:=+bluez-libs +libpthread +dbus $(INTL_DEPENDS) $(ICONV_DEPENDS)
   TITLE:=Bluetooth utilities
   URL:=http://www.bluez.org/
 endef
@@ -47,24 +50,22 @@ CONFIGURE_ARGS += \
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                LDFLAGS="$(TARGET_LDFLAGS) \
-                       -L$(STAGING_DIR)/usr/lib/libintl/lib \
-                       -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
+                       -L$(ICONV_PREFIX)/lib \
+                       -L$(INTL_PREFIX)/lib -lm" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-#copy bluetooth.conf nach /etc/dbus-1/system.d/
-
 define Package/bluez-utils/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/bluetooth
-       $(CP) $(PKG_INSTALL_DIR)/../hcid/hcid.conf $(1)/etc/bluetooth/
-       $(CP) $(PKG_INSTALL_DIR)/../rfcomm/rfcomm.conf $(1)/etc/bluetooth/
+       $(CP) $(PKG_INSTALL_DIR)/etc/bluetooth/hcid.conf $(1)/etc/bluetooth/
+       $(CP) $(PKG_INSTALL_DIR)/etc/bluetooth/rfcomm.conf $(1)/etc/bluetooth/
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/bluetooth.conf $(1)/etc/config/bluetooth
+       $(INSTALL_DATA) ./files/bluetooth.config $(1)/etc/config/bluetooth
        $(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
        $(INSTALL_DATA) ./files/bluetooth.dbus $(1)/etc/dbus-1/system.d/bluetooth.conf
        $(INSTALL_DIR) $(1)/etc/init.d