[package] update haserl to 0.9.25 (#5179)
[openwrt/svn-archive/archive.git] / utils / cifsmount / Makefile
index 713c1451ed488a54768cad347afc9d18fd96cbdf..24d3a36cb697cd73b443cbe8bd35f519767ed2e0 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -20,7 +19,9 @@ define Package/cifsmount
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=CIFS mounting helper utility
-  DESCRIPTION:=\
+endef
+
+define Package/cifsmount/description
        An user space helper utility for mounting remote CIFS shares.
 endef
 
@@ -33,8 +34,8 @@ define Build/Compile
 endef
 
 define Package/cifsmount/install
-       install -d -m0755 $(1)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/mount.cifs $(1)/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount.cifs $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,cifsmount))