[package] update libdmapsharing to 2.1.2 (#7894)
[openwrt/svn-archive/archive.git] / utils / dmidecode / Makefile
index 00af615013862520250fe8ff8ccf9651eeecf67c..518acfec30c70de773df52aeb8597251674fd818 100644 (file)
@@ -1,38 +1,36 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $ Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dmidecode
-PKG_VERSION:=2.9
+PKG_VERSION:=2.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/dmidecode/
-PKG_MD5SUM:=3dac4b1817012ffebd78671473d8f56c
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=3c9c4d55a40b78600f3b43bfa64616f9
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dmidecode
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6_X86
+  DEPENDS:=@TARGET_x86
   TITLE:=Displays BIOS informations.
-  DESCRIPTION:=\
-       Dmidecode reports information about your system's hardware\\\
-       as described in your system BIOS according to the SMBIOS/DMI\\\
-       standard.
   URL:=http://www.nongnu.org/dmidecode/
 endef
 
+define Package/dmidecode/description
+       Dmidecode reports information about your system's hardware
+       as described in your system BIOS according to the SMBIOS/DMI
+       standard.
+endef
+
 define Package/dmidecode/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin