build,travis: fix gpg verification warning
[feed/packages.git] / utils / dosfstools / Makefile
index f286bc87073ae2b63e45ba589550c8facae0d77c..52d050c4b36af83909f3eb136473da1ffa6e0210 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dosfstools
-PKG_VERSION:=3.0.28
+PKG_VERSION:=4.1
 PKG_RELEASE:=1
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
+               http://fossies.org/linux/misc
+PKG_HASH:=e6b2aca70ccc3fe3687365009dd94a2e18e82b688ed4e260e04b7412471cc173
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+
 PKG_LICENSE:=GPL-3.0+
 PKG_LICENSE_FILES:=COPYING
 
-PKG_MAINTAINER:=David Bonnes <david.bonnes@gmail.com>
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
-               http://fossies.org/linux/misc
-PKG_MD5SUM:=64e3b3a59b51d2a97d7ac38b23a124bb
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
-define Package/dosfstools/Default
+CONFIGURE_ARGS += \
+       --without-udev
+
+define Package/dosfstools
   SECTION:=utils
   CATEGORY:=Utilities
-  URL:=https://github.com/dosfstools
   SUBMENU:=Filesystem
   DEPENDS:=$(ICONV_DEPENDS)
+  TITLE:=Utilities for making and checking MS-DOS FAT filesystems
+  URL:=https://github.com/dosfstools
 endef
 
-define Package/dosfsck
-  $(call Package/dosfstools/Default)
-  TITLE:=fsck (fsck.fat) utility from dosfstools
-endef
-
-define Package/dosfslabel
-  $(call Package/dosfstools/Default)
-  TITLE:=fslabel (fatlabel) utility from dosfstools
-endef
-
-define Package/mkdosfs
-  $(call Package/dosfstools/Default)
-  TITLE:=mkfs (mkfs.fat) utility from dosfstools
-endef
-
-define Package/dosfsck/description
-       Utilities to create and check MS-DOS FAT filesystems.
-       (fsck.vfat and fsck.fat for checking integrity of FAT volumes)
-endef
-
-define Package/dosfslabel/description
-       Utilities to create and check MS-DOS FAT filesystems.
-       (fatlabel for reading and writing labels of FAT volumes)
-endef
-
-define Package/mkdosfs/description
-       Utilities to create and check MS-DOS FAT filesystems.
-       (mkfs.vfat and mkfs.fat for creating FAT volumes)
-endef
-
-LDFLAGS+=$(ICONV_LDFLAGS)
-LDLIBS+=-liconv
-
-define Build/Configure
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               OPTFLAGS="$(TARGET_CFLAGS) -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE" \
-               PREFIX="/usr" \
-               SBINDIR="/usr/sbin" \
-               LDFLAGS="$(LDFLAGS)" \
-               LDLIBS="$(LDLIBS)" \
-               all
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               OPTFLAGS="$(TARGET_CFLAGS) -D_FILE_OFFSET_BITS=64" \
-               PREFIX="$(PKG_INSTALL_DIR)/usr" \
-               SBINDIR="$(PKG_INSTALL_DIR)/usr/sbin" \
-               install-bin
-endef
-
-define Package/dosfsck/install
-       $(INSTALL_DIR) $(1)/lib/functions/fsck
-       $(INSTALL_DATA) ./files/dosfsck.sh $(1)/lib/functions/fsck/
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fsck.fat $(1)/usr/sbin/
-       (cd $(1)/usr/sbin; ln -sf fsck.fat fsck.msdos; ln -sf fsck.fat fsck.vfat; ln -sf fsck.fat dosfsck)
+define Package/dosfstools/description
+       The dosfstools package includes the mkfs.fat and fsck.fat utilities, which respectively make and check MS-DOS FAT filesystems.
 endef
 
-define Package/dosfslabel/install
+define Package/dosfstools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fatlabel $(1)/usr/sbin/
-endef
-
-define Package/mkdosfs/install
-       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fsck.fat $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mkfs.fat $(1)/usr/sbin/
-       (cd $(1)/usr/sbin; ln -sf mkfs.fat mkfs.msdos; ln -sf mkfs.fat mkfs.vfat)
 endef
 
-$(eval $(call BuildPackage,dosfsck))
-$(eval $(call BuildPackage,dosfslabel))
-$(eval $(call BuildPackage,mkdosfs))
+$(eval $(call BuildPackage,dosfstools))