[package] fix ccache compilation with mg (#5097)
[openwrt/svn-archive/archive.git] / utils / dosfstools / Makefile
index 46dd99067a93bacc06c61b476d5c01b8ae2c2256..642719d3c525a57bb4b0df8d83f2ed657c071469 100644 (file)
@@ -1,24 +1,19 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dosfstools
 PKG_VERSION:=2.11
-PKG_RELEASE:=1
+PKG_RELEASE:=4
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_MD5SUM:=407d405ade410f7597d364ab5dc8c9f6
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
 PKG_SOURCE_URL:=ftp://ftp.uni-erlangen.de/pub/Linux/LOCAL/dosfstools/
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=407d405ade410f7597d364ab5dc8c9f6
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,30 +21,38 @@ define Package/dosfstools
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=MS-DOS FAT filesystems utilities
-  DESCRIPTION:=MS-DOS FAT filesystems utilities.\\\
-    Utilities to create and check MS-DOS FAT filesystems.
   URL:=ftp://ftp.uni-erlangen.de:/pub/Linux/LOCAL/dosfstools/
+  SUBMENU:=filesystem
+endef
+
+define Package/dosfstools/description
+       Utilities to create and check MS-DOS FAT filesystems.
 endef
 
 define Build/Configure
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                OPTFLAGS="$(TARGET_CFLAGS) -D_FILE_OFFSET_BITS=64" \
-               PREFIX="$(PKG_INSTALL_DIR)" \
-               all install
+               PREFIX="/usr" \
+               SBINDIR="/usr/sbin" \
+               all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               OPTFLAGS="$(TARGET_CFLAGS) -D_FILE_OFFSET_BITS=64" \
+               PREFIX="$(PKG_INSTALL_DIR)/usr" \
+               SBINDIR="$(PKG_INSTALL_DIR)/usr/sbin" \
+               install
 endef
 
 define Package/dosfstools/install
-       install -d -m0755 $(1)/sbin
-       $(CP) $(PKG_INSTALL_DIR)/sbin/dosfsck $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/fsck.{msdos,vfat} $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/mkdosfs $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/mkfs.{msdos,vfat} $(1)/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dosfsck $(1)/usr/sbin/
+       (cd $(1)/usr/sbin; ln -sf dosfsck fsck.msdos; ln -sf dosfsck fsck.vfat)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mkdosfs $(1)/usr/sbin/
+       (cd $(1)/usr/sbin; ln -sf mkdosfs mkfs.msdos; ln -sf mkdosfs mkfs.vfat)
 endef
 
 $(eval $(call BuildPackage,dosfstools))