[package] also install rbash (#6927)
[openwrt/svn-archive/archive.git] / utils / hd-idle / Makefile
index 05436876379f80bcf7b41813eff8bcd73d118ec1..922a7d1af5e9f7e7c2d702f267734b414fb93807 100644 (file)
@@ -4,22 +4,23 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hd-idle
-PKG_REV:=HEAD
+PKG_REV:=20081006
 PKG_VERSION:=$(PKG_REV)
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=:pserver:anonymous@hd-idle.cvs.sourceforge.net:/cvsroot/hd-idle
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)
-PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_SOURCE_PROTO:=cvs
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
+PKG_MD5SUM:=4902893f901cc0bfcccef3d30d2e5d5b
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+# CVS disabled. The package must not be a moving target by itself
+#PKG_SOURCE_URL:=:pserver:anonymous@hd-idle.cvs.sourceforge.net:/cvsroot/hd-idle
+#PKG_SOURCE_PROTO:=cvs
+#PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(REV)
+#PKG_SOURCE_VERSION:=$(PKG_REV)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,10 +29,11 @@ define Package/hd-idle
   CATEGORY:=Utilities
   TITLE:=Another idle-daemon for attached hard drives
   SUBMENU:=disc
+  URL:=http://hd-idle.sourceforge.net/
 endef
 
 define Build/Compile
-        $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/$(PKG_NAME).c
+       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/$(PKG_NAME).c
 endef
 
 define Package/hd-idle/install