[packages] pcre: Add C++ wrapper for pcre package (#9331)
[openwrt/svn-archive/archive.git] / utils / hdparm / Makefile
index 2a201b7db00f0029a7c373b1e47dd69c0423656d..59f7a434512b6e885604bdb597fc2338263de14f 100644 (file)
@@ -1,43 +1,38 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hdparm
-PKG_VERSION:=8.1
+PKG_VERSION:=9.37
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=87c1512497195204034503665f71f5fc
+PKG_MD5SUM:=0bb94ddd1bedd5c02b1ca62f1caaf6de
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hdparm
   SECTION:=utils
   CATEGORY:=Utilities
+  SUBMENU:=disc
   TITLE:=Hard disk drive configuration utilitity
   URL:=http://sourceforge.net/projects/hdparm/
+  MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
 endef
 
 define Package/hdparm/description
-       Tune hard disk parameters for high performance.
-       Get/set hard disk parameters for Linux IDE drives.
-       Primary use is for enabling irq-unmasking and IDE multiplemode.
+ get/set SATA/IDE device parameters
 endef
 
-MAKE_FLAGS += \
-       CFLAGS="$(EXTRA_CFLAGS)" \
-       LDFLAGS="$(EXTRA_LDFLAGS)" \
-
 define Package/hdparm/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/sbin
 endef
 
 $(eval $(call BuildPackage,hdparm))