Remove broken patch which was causing the path to be incremented as well as the file...
[openwrt/svn-archive/archive.git] / utils / heyu / Makefile
index e93eca2c7f8d6acde940bee7cee694d9e3dacb61..ed6ff81e01799a0bb9dd6968ca25c0db9857f8e5 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,13 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=heyu
-PKG_VERSION:=2.0beta.5
+PKG_VERSION:=2.1.3
 PKG_RELEASE:=1
-PKG_MD5SUM:=8289d5ca5b972333a72bc0fc3e640c13
-PKG_SOURCE_URL:=http://heyu.tanj.com/download/
+
 PKG_SOURCE:=heyu-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://heyu.tanj.com/download/
+PKG_MD5SUM:=d40f4ebf7d42fb896e7c6300227906eb
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,7 +25,6 @@ define Package/heyu
   CATEGORY:=Utilities
   DEPENDS:=+setserial
   TITLE:=X10 home automation control using a CM11A
-  DESCRIPTION:=10 home automation control using the CM11A serial device.
   URL:=http://heyu.tanj.com/heyu2/
 endef
 
@@ -31,17 +32,17 @@ define Package/heyu/conffiles
 /etc/heyu/x10.conf
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
-               CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT -DHASTZ"
+define Build/Compile
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) \$$$$(DFLAGS)" \
+       )
 endef
 
 define Package/heyu/install    
-       install -d -m0755 $(1)/etc/$(PKG_NAME)
-       install -m0644 ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
-       install -d -m0755 $(1)/usr/bin
-       install -m0644 $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
+       $(INSTALL_DATA) ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
 endef
 
 $(eval $(call BuildPackage,heyu))