[packages] bluez-utils: Add configuration and init scripts for hci serial devices
[openwrt/svn-archive/archive.git] / utils / heyu / Makefile
index 8003d52392b525960873502ebc8741f4d65c3dc3..ee7fa275a4701c00eb8fa37e2438b73edcb9da10 100644 (file)
@@ -4,20 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=heyu
-PKG_VERSION:=2.0beta.5
+PKG_VERSION:=2.3.2
 PKG_RELEASE:=1
 
-PKG_SOURCE:=heyu-$(PKG_VERSION).tgz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://heyu.tanj.com/download/
-PKG_MD5SUM:=8289d5ca5b972333a72bc0fc3e640c13
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=af3eeeaa8c432e5b3510f4df6dd39f4f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,6 +25,18 @@ define Package/heyu
   URL:=http://heyu.tanj.com/heyu2/
 endef
 
+define Package/heyu/description
+       HEYU is a text-based console program for remotely controlling lights
+       and appliances in the home or office.   It is made available under a
+       free and open source license.
+
+       Heyu uses the CM11A computer interface to send and receive X10 control
+       signals over the AC power lines to modules which can turn On, Off, or
+       Dim attached lamps or appliances.   It can store a schedule of timed
+       events in the CM11A memory for execution when the computer is turned
+       off or disconnected.
+endef
+
 define Package/heyu/conffiles
 /etc/heyu/x10.conf
 endef
@@ -40,10 +48,10 @@ define Build/Compile
 endef
 
 define Package/heyu/install    
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
-       install -d -m0755 $(1)/etc/$(PKG_NAME)
-       install -m0644 ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/heyu $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
+       $(INSTALL_DATA) ./files/x10.conf $(1)/etc/$(PKG_NAME)/x10.conf
 endef
 
 $(eval $(call BuildPackage,heyu))