at: bump version
[feed/packages.git] / utils / i2c-tools / Makefile
index c66c80ea8d40b67cb7f4abb24b83d182be85b9e2..c98ab8bbe7aefec1e1854c4a79ec56e86f96eb16 100644 (file)
@@ -15,7 +15,7 @@ PKG_SOURCE_URL:=http://dl.lm-sensors.org/i2c-tools/releases/ \
                 http://fossies.org/linux/misc/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=7104a1043d11a5e2c7b131614eb1b962
+PKG_HASH:=db5e69f2e2a6e3aa2ecdfe6a5f490b149c504468770f58921c8c5b8a7860a441
 
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=PACKAGE_python-smbus:python
@@ -26,6 +26,7 @@ PKG_LICENSE_FILES:=COPYING
 
 include $(INCLUDE_DIR)/package.mk
 $(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
 
 define Package/i2c/Default
   URL:=http://lm-sensors.org/wiki/I2CTools
@@ -48,6 +49,15 @@ define Package/python-smbus
   DEPENDS:=+python-light
 endef
 
+define Package/python3-smbus
+  $(call Package/i2c/Default)
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Python bindings for the SMBUS
+  DEPENDS:=+python3-light
+endef
+
 define Package/i2c-tools/description
  This package contains an heterogeneous set of I2C tools for Linux. These tools
  were originally part of the lm-sensors package.
@@ -57,6 +67,10 @@ define Package/python-smbus/description
  This package contain the python bindings for Linux SMBus access through i2c-dev.
 endef
 
+define Package/python3-smbus/description
+ This package contain the python bindings for Linux SMBus access through i2c-dev.
+endef
+
 TARGET_CPPFLAGS += -I$(PKG_BUILD_DIR)/include
 
 ifdef CONFIG_PACKAGE_python-smbus
@@ -68,6 +82,15 @@ ifdef CONFIG_PACKAGE_python-smbus
   endef
 endif
 
+ifdef CONFIG_PACKAGE_python3-smbus
+  define Build/Compile/python3-smbus
+       $(if $(Build/Compile/Py3Mod),,@echo Python3 packaging code not found.; false)
+       $(call Build/Compile/Py3Mod,./py-smbus/, \
+               install --prefix="$(PKG_INSTALL_DIR)/usr", \
+       )
+  endef
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                LINUX="$(LINUX_DIR)" \
@@ -76,6 +99,7 @@ define Build/Compile
                LDFLAGS="$(TARGET_LDFLAGS)" \
                CFLAGS="$(TARGET_CFLAGS)"
        $(Build/Compile/python-smbus)
+       $(Build/Compile/python3-smbus)
 endef
 
 define Package/i2c-tools/install
@@ -87,9 +111,15 @@ define Package/i2c-tools/install
 endef
 
 define PyPackage/python-smbus/filespec
-+|$(PYTHON_PKG_DIR)/smbus.so
++|$(PYTHON_PKG_DIR)
+endef
+
+define PyPackage/python3-smbus/filespec
++|$(PYTHON3_PKG_DIR)
 endef
 
 $(eval $(call BuildPackage,i2c-tools))
 $(eval $(call PyPackage,python-smbus))
 $(eval $(call BuildPackage,python-smbus))
+$(eval $(call PyPackage,python3-smbus))
+$(eval $(call BuildPackage,python3-smbus))