klish: Fix build errors with external toolchains
[feed/packages.git] / utils / klish / Makefile
index 4374e276bb25e87079b15eca6d9721360ef77acd..0a63a1053b7f3a6637f29412666ff00bd39eb088 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=klish
 PKG_VERSION:=2.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://libcode.org/attachments/download/66/
@@ -50,6 +50,9 @@ define Package/klish/description
  More information about these tools is to be found on the klish web site.
 endef
 
+TARGET_LDFLAGS += -lxml2 -lz
+TARGET_CFLAGS += -D_XOPEN_SOURCE=500
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-libxml2 \