Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / utils / klish / Makefile
index 4374e276bb25e87079b15eca6d9721360ef77acd..7ca229fb654bb923d395b74c89dd44bc492b3424 100644 (file)
@@ -10,14 +10,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=klish
 PKG_VERSION:=2.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://libcode.org/attachments/download/66/
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENCE
 PKG_MAINTAINER:=Takashi Umeno <umeno.takashi@gmail.com>
-PKG_MD5SUM:=7dfe46d474c02c86946c1d7a461ae549
+PKG_HASH:=70528039da9c5fdfadaea325ab6243cdabef627da0398335312e08d90ab415f8
 
 PKG_INSTALL:=1
 
@@ -50,6 +50,9 @@ define Package/klish/description
  More information about these tools is to be found on the klish web site.
 endef
 
+TARGET_LDFLAGS += -lxml2 -lz
+TARGET_CFLAGS += -D_XOPEN_SOURCE=500
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --with-libxml2 \