fix typo in init-script (closes: #1518)
[openwrt/svn-archive/archive.git] / utils / lilo / Makefile
index ec8c5f20fb2d4c49b3e018a861278ffc0682fcf7..c77e245fc91eb157a863220d3c96d9f46e17815d 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/lilo
   SECTION:=base
   CATEGORY:=Boot Loaders
-  DEPENDS:=@LINUX_2_6_X86||LINUX_2_4_X86
+  DEPENDS:=@LINUX_2_6_X86
   TITLE:=lilo
   URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
 endef
@@ -38,9 +38,9 @@ define Build/Compile
 endef
 
 define Package/lilo/install
-       install -d -m0755 $(1)/sbin
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_BUILD_DIR)/lilo.static $(1)/sbin/lilo
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) ./files/lilo.conf $(1)/etc/
        $(CP) ./files/boot.msg $(1)/etc/
 endef