[PATCH] Update Quicktun to version 2.1.7
[openwrt/svn-archive/archive.git] / utils / mc / Makefile
index d0f979155f0bf818265ad60285871ee16cc7600c..81cf9fef6649cdaf7491468b60fc48faf59971d2 100644 (file)
@@ -1,79 +1,74 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mc
-PKG_VERSION:=4.6.1
-PKG_RELEASE:=2
+PKG_VERSION:=4.7.5.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/
-PKG_MD5SUM:=18b20db6e40480a53bac2870c56fc3c4
+PKG_SOURCE_URL:=http://www.midnight-commander.org/downloads/
+PKG_MD5SUM:=9fdfe7c0fcff362436eb35fcd1adf0fd
 
-PKG_BUILD_DEPENDS:=glib1 libncurses
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/mc
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+glib1 +libncurses
+  DEPENDS:=+glib2 +libncurses +libiconv
   TITLE:=midnight commander - a powerful file manager
-  URL:=http://www.ibiblio.org/mc/
-  SUBMENU:=mc
+  URL:=http://www.midnight-commander.org/
+  SUBMENU:=filemanager
+  MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
 endef
 
 define Package/mc/description
-       GNU Midnight Commander is a text-mode full-screen file manager. 
-       It uses a two panel interface and a subshell for command execution. 
-       It includes an internal editor with syntax highlighting and an 
-       internal viewer with support for binary files. Also included is 
-       Virtual Filesystem (VFS), that allows files on remote systems 
-       (e.g. FTP, SSH, SMB servers) and files inside archives to be 
-       manipulated like real files.
+ GNU Midnight Commander is a visual file manager, licensed under GNU General
+ Public License and therefore qualifies as Free Software. It's a feature rich
+ full-screen text mode application that allows you to copy, move and delete
+ files and whole directory trees, search for files and run commands in the
+ subshell.
 endef
 
 CONFIGURE_ARGS += \
-       --prefix=/usr \
-       --disable-nls \
-       --with-included-gettext \
-       --with-ncurses \
-       --without-sco \
-       --without-sunos-curses \
-       --without-osf1-curses \
-       --without-vcurses \
+       --enable-utf8 \
+       --disable-vfs \
+       --with-screen=ncurses \
+       --without-edit \
        --without-gpm-mouse \
-       --without-hsc \
-       --without-termnet \
-       --without-debug \
-       --without-efence \
-       --without-terminfo \
-       --without-termcap \
-       --without-slang \
-       --without-vfs \
-       --without-netrc \
-       --without-ext2undel \
-       --without-catgets \
-       --without-x \
-       --without-tk \
-       --without-xview \
        --without-subshell \
-       --disable-glibtest \
-       --with-glib12 \
-       --with-glib-prefix="$(STAGING_DIR)/usr" \
-       , \
-       PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
+       --without-x
+
+AM_HOST=$(firstword $(wildcard $(STAGING_DIR_HOST)/share/automake-*))
+
+define Build/Prepare
+       $(Build/Prepare/Default)
+       for script in config.guess config.sub depcomp install-sh missing; do \
+               rm -f $(PKG_BUILD_DIR)/config/$$$$script; \
+               ln -s $(AM_HOST)/$$$$script $(PKG_BUILD_DIR)/config/$$$$script; \
+       done
+endef
 
 define Package/mc/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin
-       ln -sf mc $(1)/usr/bin/mcedit
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/mc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/mc.menu $(1)/etc/mc
+       $(INSTALL_DIR) $(1)/etc/mc/skins
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/skins/default.ini $(1)/etc/mc/skins
+endef
+
+define Package/mc/conffiles
+/etc/mc/mc.menu
+/etc/mc/skins/default.ini
 endef
 
 $(eval $(call BuildPackage,mc))