[net] printing: Removed printing submenu as it had only two entries.
[openwrt/svn-archive/archive.git] / utils / mgetty / Makefile
index 100a1260dc4d3d5d850f7ba70c07c1170f16442d..8e2aec4b4e9737500ac3fe4dc8cc8624eef6e488 100644 (file)
@@ -4,22 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mgetty
-PKG_VERSION:=1.1.35
-PKG_XVERSION:=Feb22
+PKG_VERSION:=1.1.36
+PKG_XVERSION:=Jun15
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION)-$(PKG_XVERSION).tar.gz
 PKG_SOURCE_URL:=ftp://alpha.greenie.net/pub/mgetty/source/1.1
-PKG_MD5SUM:=6805f8e31423bb777be80e3a856001cb
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=0320e98c6b86bcca48fc5f355b94ead4
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,7 +22,11 @@ define Package/mgetty
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=A data/fax solution for your analog modem
-  DESCRIPTION:=A data/fax solution for your analog modem.
+  URL:=http://mgetty.greenie.net/
+endef
+
+define Package/mgetty/description
+A data/fax solution for your analog modem.
 endef
 
 define Build/Configure
@@ -92,8 +91,8 @@ define Build/Compile
 endef
 
 define Package/mgetty/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 \
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/faxq \
                $(PKG_INSTALL_DIR)/usr/bin/faxrm \
                $(PKG_INSTALL_DIR)/usr/bin/faxrunq \
@@ -103,13 +102,13 @@ define Package/mgetty/install
                $(PKG_INSTALL_DIR)/usr/bin/pbm2g3 \
                $(PKG_INSTALL_DIR)/usr/bin/sff2g3 \
                $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 \
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/sbin/mgetty \
                $(PKG_INSTALL_DIR)/usr/sbin/sendfax \
                $(PKG_INSTALL_DIR)/usr/sbin/faxrunqd \
                $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/lib/mgetty+sendfax
+       $(INSTALL_DIR) $(1)/usr/lib/mgetty+sendfax
        install -m4755 \
                $(PKG_INSTALL_DIR)/usr/lib/mgetty+sendfax/faxq-helper \
                $(1)/usr/lib/mgetty+sendfax/
@@ -117,7 +116,7 @@ define Package/mgetty/install
                $(PKG_INSTALL_DIR)/usr/lib/mgetty+sendfax/cour25n.pbm \
                $(PKG_INSTALL_DIR)/usr/lib/mgetty+sendfax/cour25.pbm \
                $(1)/usr/lib/mgetty+sendfax/
-       install -d -m0755 $(1)/etc/mgetty+sendfax
+       $(INSTALL_DIR) $(1)/etc/mgetty+sendfax
        install -m600 \
                $(PKG_INSTALL_DIR)/etc/mgetty+sendfax/dialin.config \
                $(PKG_INSTALL_DIR)/etc/mgetty+sendfax/faxheader \