[packages] mtd-utils: upgrade to latest git version
[openwrt/svn-archive/archive.git] / utils / mtd-utils / Makefile
index ce1c93d9b6c5c41ef2590faab702ce15e74873f1..96e2f125eec7c9f745e808903058c005cb68ab84 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2009-2010 OpenWrt.org
+#
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,75 +8,69 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtd-utils
-PKG_REV:=a2d010f8fca904fffa3c6e5a5d148cc96a37a08a
-PKG_VERSION:=20090227
+PKG_REV:=ab8c6fb93ce9db0f09401c4b819b0b277dc00340
+PKG_VERSION:=1.5.0
 PKG_RELEASE:=1
 PKG_INSTALL:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://git.infradead.org/mtd-utils.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 
+PKG_BUILD_DEPENDS:=util-linux
+
 include $(INCLUDE_DIR)/package.mk
 
 FILES:= \
-       ubiupdatevol \
-       flash_otp_info \
-       nandtest \
-       ubimkvol \
-       ubigen \
-       serve_image \
-       recv_image \
-       ubinfo \
-       ubirename \
-       mkpfi \
-       nandwrite \
-       flash_eraseall \
-       mkbootenv \
-       ftl_format \
-       nand2bin \
-       ubiattach \
-       nftl_format \
-       nanddump \
-       ubinize \
+       doc_loadbios \
        docfdisk \
-       ubimirror \
-       ubicrc32.pl \
-       ftl_check \
+       flash_erase \
+       flash_eraseall:+mtd-utils-flash-erase \
+       flash_lock \
+       flash_otp_dump \
+       flash_otp_lock \
+       flash_otp_write \
+       flash_unlock \
        flashcp \
+       ftl_check \
+       ftl_format \
        jffs2dump \
-       ubiformat \
-       ubidetach \
-       flash_lock \
-       bin2nand \
-       pfiflash \
+       jffs2reader \
+       mkfs.jffs2:+zlib \
+       mkfs.ubifs:+libuuid:+liblzo:+zlib \
        mtd_debug \
-       pddcustomize \
-       flash_unlock \
-       doc_loadbios \
+       mtdinfo \
+       nanddump \
+       nandtest \
+       nandwrite \
        nftldump \
-       mkfs.jffs2 \
-       flash_info \
+       nftl_format \
+       recv_image \
+       rfddump \
+       rfdformat \
+       serve_image \
+       sumtool \
+       ubiattach \
        ubicrc32 \
+       ubidetach \
+       ubiformat \
+       ubimkvol \
+       ubinfo \
+       ubinize \
+       ubirename \
        ubirmvol \
-       unubi \
-       pfi2bin \
-       mkfs.ubifs \
-       sumtool \
-       flash_erase \
-       rfddump \
-       flash_otp_dump \
-       rfdformat
+       ubirsvol \
+       ubiupdatevol
 
 define PartGen
-define Package/mtd-utils-$(subst _,-,$(1))
-  TITLE:=MTD $(1)
+define Package/mtd-utils-$(subst _,-,$(firstword $(subst :, ,$(1))))
+  TITLE:=$(firstword $(subst :, ,$(1))) package from mtd-utils
   URL:=http://www.linux-mtd.infradead.org/
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=mtd-utils +zlib +liblzo +libuuid
+  DEPENDS:=mtd-utils $(wordlist 2,$(words $(subst :, ,$(1))),$(subst :, ,$(1)))
 endef
 endef
 
@@ -84,6 +78,7 @@ define Package/mtd-utils
   TITLE:=Utilities for flash info/debug
   SECTION:=utils
   CATEGORY:=Utilities
+  URL:=http://www.linux-mtd.infradead.org/
   MENU:=1
 endef
 
@@ -101,20 +96,14 @@ MAKE_FLAGS += \
        DESTDIR="$(PKG_INSTALL_DIR)" \
        BUILDDIR="$(PKG_BUILD_DIR)" \
        LDLIBS+="$(LIBGCC_S)" \
-       WITHOUT_XATTR=1
-
-ifeq ($(CONFIG_LINUX_2_4),y)
-MAKE_FLAGS += \
-       SUBDIRS=""
-endif
+       WITHOUT_XATTR=1 \
+       WITHOUT_LZO=1
 
 define PartInstall
-define Package/mtd-utils-$(subst _,-,$(1))/install
-       $(INSTALL_DIR) \
-               $$(1)/usr/sbin
-
+define Package/mtd-utils-$(subst _,-,$(firstword $(subst :, ,$(1))))/install
+       $(INSTALL_DIR) $$(1)/usr/sbin
        $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/sbin/$(1) \
+               $(PKG_INSTALL_DIR)/usr/sbin/$(firstword $(subst :, ,$(1))) \
                $$(1)/usr/sbin/
 endef
 endef
@@ -122,4 +111,4 @@ endef
 $(foreach file,$(FILES),$(eval $(call PartInstall,$(file))))
 
 $(eval $(call BuildPackage,mtd-utils))
-$(foreach file,$(FILES),$(eval $(call BuildPackage,mtd-utils-$(subst _,-,$(file)))))
+$(foreach file,$(FILES),$(eval $(call BuildPackage,mtd-utils-$(subst _,-,$(firstword $(subst :, ,$(file)))))))