Add maemo-kexec helper scripts for booting maemo from openwrt on the Nokia n810.
[openwrt/svn-archive/archive.git] / utils / nano / Makefile
index 9ac6cef5fc7d1672db471724f710a128c005d3df..2934c29f370d365f73830e057b5c2ff4930566f2 100644 (file)
@@ -1,35 +1,37 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nano
-PKG_VERSION:=2.0.7
+PKG_VERSION:=2.2.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.0
-PKG_MD5SUM:=16187fed2bdefec6275ece6401ce4cd2
+PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.2
+PKG_MD5SUM:=6304308afb1f7ef4a5e93eb99206632a
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/nano
+  SUBMENU:=Editors
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libncurses
   TITLE:=An enhanced clone of the Pico text editor
   URL:=http://www.nano-editor.org/
-  SUBMENU:=editors
+  MAINTAINER:=Bernhard Loos <bernhardloos@googlemail.com>
+  DEPENDS:=+libncurses
 endef
 
 define Package/nano/description
-       GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
-       of the Pico text editor..
+  GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
+  of the Pico text editor.
 endef
 
 CONFIGURE_ARGS += \
@@ -41,9 +43,9 @@ CONFIGURE_ARGS += \
 CONFIGURE_VARS += \
        ac_cv_header_regex_h=no \
 
-define Package/nano/install    
+define Package/nano/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,nano))