Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / utils / ncdu / Makefile
index 425d30ea623f97523f47eff7212349f75c10893a..1e01c5c493a262d4b6a733dde23e2c25a38f31c0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ncdu
-PKG_VERSION:=1.10
+PKG_VERSION:=1.12
 PKG_RELEASE=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://dev.yorhel.nl/download
-PKG_MD5SUM:=7535decc8d54eca811493e82d4bfab2d
+PKG_SOURCE_URL:=https://dev.yorhel.nl/download
+PKG_HASH:=820e4e4747a2a2ec7a2e9f06d2f5a353516362c22496a10a9834f871b877499a
 
 PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -26,10 +27,10 @@ define Package/ncdu
   SUBMENU:=Filesystem
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libncursesw
+  DEPENDS:=+libncurses
   TITLE:=ncurses disk usage viewer
   MAINTAINER:=Charles Lehner <celehner1@gmail.com>
-  URL:=http://dev.yorhel.nl/ncdu
+  URL:=https://dev.yorhel.nl/ncdu
 endef
 
 define Package/ncdu/description
@@ -38,9 +39,11 @@ define Package/ncdu/description
   directories and show percentages of disk usage with ncurses library.
 endef
 
+CONFIGURE_ARGS += --with-ncurses
+
 define Package/ncdu/install
-  $(INSTALL_DIR) $(1)/usr/bin
-  $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ncdu $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ncdu $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ncdu))