[packages] usb-modeswitch: update to v1.0.7 (#6522)
[openwrt/svn-archive/archive.git] / utils / owfs / Makefile
index 0f3260fdf8cd7f324daa277457504010f44584f0..95576d90a15232a82ddcf52c8a73c2ce78670232 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,30 +7,47 @@
 
 include $(TOPDIR)/rules.mk
 PKG_NAME:=owfs
-PKG_VERSION:=2.7p7
+PKG_VERSION:=2.7p21
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=4c189f64a1a6110bef19639a36c3b0e1
+PKG_MD5SUM:=8aea6f3bb0dc9fdb52ed3f0e9d84fa79
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
-
 #
 # templates
 #
 
-define Package/owfs/Default
+define Package/$(PKG_NAME)/Default
   TITLE:=OWFS (1-Wire File System)
   URL:=http://owfs.sourceforge.net/
-endef
-
-define Package/owfs/Server
-  $(call Package/owfs/Default)
-  DEPENDS:=+owfs
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Filesystem
+endef
+
+define Package/$(PKG_NAME)/Default/description
+  OWFS is a suite of programs that designed to make the 1-wire bus and its 
+  devices easily accessible. The underlying priciple is to create a virtual 
+  filesystem, with the unique ID being the directory, and the individual 
+  properties of the device are represented as simple files that can be read 
+  and written.
+
+  Details of the individual slave or master design are hidden behind a 
+  consistent interface. The goal is to provide an easy set of tools for a 
+  software designer to create monitoring or control applications. There are 
+  some performance enhancements in the implementation, including data caching, 
+  parallel access to bus masters, and aggregation of device communication. 
+  Still the fundemental goal has been ease of use, flexibility and correctness 
+  rather than speed.
+endef
+
+define Package/owfs-server
+  $(call Package/$(PKG_NAME)/Default)
+  DEPENDS:=+libow +libpthread
 endef
 
 define Package/owfs/Library
@@ -46,7 +63,7 @@ define Package/owfs/Utility
   DEPENDS:=+libow
 endef
 
-define Package/owfs/ServerInstall
+define Package/owfs-server/Install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(2) $(1)/usr/bin/
 endef
@@ -62,19 +79,24 @@ define Package/libow
   TITLE:=OWFS - common shared library
 endef
 
+define Package/libow/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS library.
+endef
+
 define Package/libow-capi
   $(call Package/owfs/Library)
   DEPENDS:=+libow
   TITLE:=OWFS - C-API library
 endef
 
-define Package/libow-perl
-  $(call Package/owfs/Library)
-  DEPENDS:=+libow +perlbase-autoloader +perlbase-config +perlbase-dynaloader +perlbase-essential +perlbase-io
-  TITLE:=OWFS - Perl-API library
+define Package/libow-capi/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS C-API library.
 endef
 
-
 #
 # utilities
 #
@@ -84,68 +106,73 @@ define Package/owshell
   TITLE:=OWFS - shell utilities
 endef
 
+define Package/owshell/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS shell utilities.
+endef
+
 define Package/owfs
   $(call Package/owfs/Utility)
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS+=+kmod-fuse +libfuse +fuse-utils
+  # libfuse depends on kmod-fuse, no need to declare dependency
+  DEPENDS+= +libfuse +fuse-utils
   TITLE:=OWFS - fuse file system
 endef
 
+define Package/owfs/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS fuse filesystem.
+endef
 
 #
 # network daemons
 #
 
 define Package/owhttpd
-  $(call Package/owfs/Server)
+  $(call Package/owfs-server)
   TITLE:=OWFS - http server
 endef
 
+define Package/owhttpd/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS http server.
+endef
+
 define Package/owftpd
-  $(call Package/owfs/Server)
+  $(call Package/owfs-server)
   TITLE:=OWFS - ftp server
 endef
 
+define Package/owftpd/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS ftp server.
+endef
+
 define Package/owserver
-  $(call Package/owfs/Server)
+  $(call Package/owfs-server)
   TITLE:=OWFS - network server
 endef
 
-
+define Package/owserver/description
+  $(call Package/$(PKG_NAME)/Default/description)
+  
+  This package contains the OWFS network server.
+endef
 
 PKG_CONFIGURE_OPTS:= \
                --enable-zero \
                --disable-parport \
                --disable-ownfsd \
                --disable-ownet \
-               --disable-owpython
-
-
-ifneq ($(CONFIG_PACKAGE_libow-perl),)
-PKG_CONFIGURE_OPTS+= --enable-libow-perl
-ENABLE_SWIG:=1
-else
-PKG_CONFIGURE_OPTS+= --disable-libow-perl
-endif
-ifneq ($(CONFIG_PACKAGE_owtcl),)
-PKG_CONFIGURE_OPTS+= --enable-owtcl
-ENABLE_SWIG:=1
-else
-PKG_CONFIGURE_OPTS+= --disable-owtcl
-PKG_CONFIGURE_OPTS+= --disable-owside
-endif
-ifneq ($(CONFIG_PACKAGE_owphp),)
-PKG_CONFIGURE_OPTS+= --enable-owphp
-ENABLE_SWIG:=1
-else
-PKG_CONFIGURE_OPTS+= --disable-owphp
-endif
-ifneq ($(ENABLE_SWIG),)
-PKG_CONFIGURE_OPTS+= --enable-swig
-else
-PKG_CONFIGURE_OPTS+= --disable-swig
-endif
+               --disable-owpython \
+               --disable-libow-perl \
+               --disable-owphp \
+               --disable-owtcl \
+               --disable-owside \
+               --disable-swig
 
 CONFIGURE_ARGS += \
        --prefix=/usr \
@@ -154,7 +181,6 @@ CONFIGURE_ARGS += \
        --enable-owserver \
        --enable-owhttpd \
        --enable-owfs \
-       --with-perl5=$(STAGING_DIR)/usr/bin/perl \
        --with-fuseinclude="$(STAGING_DIR)/usr/include" \
        --with-fuselib="$(STAGING_DIR)/usr/lib" \
        $(PKG_CONFIGURE_OPTS) \
@@ -166,12 +192,12 @@ define Build/Configure
                rm -rf config.{status,cache} ; \
                ./bootstrap ; \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) $(CFLAGS_LARGEFILE)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                lt_sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
                lt_sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
-               shrext_cmds=".so"
+               shrext_cmds=".so" \
                ./configure \
                        $(CONFIGURE_ARGS) \
        );
@@ -187,16 +213,13 @@ define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP)   $(PKG_INSTALL_DIR)/usr/include/{owcapi,owfs_config}.h $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libow.{a,so} $(PKG_INSTALL_DIR)/usr/lib/libowcapi.{a,so} $(STAGING_DIR)/usr/lib/
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libow-*.so.* $(PKG_INSTALL_DIR)/usr/lib/libowcapi-*.so.* $(STAGING_DIR)/usr/lib/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libow-*.so* $(PKG_INSTALL_DIR)/usr/lib/libowcapi-*.so* $(STAGING_DIR)/usr/lib/
 endef
 
 define Build/UninstallDev
        rm -rf  $(STAGING_DIR)/usr/include/{libow-capi,owfs_config}.h \
-               $(STAGING_DIR)/usr/lib/libow-capi-*.so.* \
-               $(STAGING_DIR)/usr/lib/libow-*.so.* \
-               $(STAGING_DIR)/usr/lib/libow-capi.{a,so} \
-               $(STAGING_DIR)/usr/lib/libow.{a,so}
+               $(STAGING_DIR)/usr/lib/libow-capi-*.so* \
+               $(STAGING_DIR)/usr/lib/libow-*.so*
 endef
 
 
@@ -215,36 +238,30 @@ endef
 
 
 define Package/owserver/install
-       $(call Package/owfs/ServerInstall,$(1),owserver,70)
+       $(call Package/owfs-server/Install,$(1),owserver,70)
 endef
 
 define Package/owhttpd/install
-       $(call Package/owfs/ServerInstall,$(1),owhttpd,80)
+       $(call Package/owfs-server/Install,$(1),owhttpd,80)
 endef
 
 define Package/owftpd/install
-       $(call Package/owfs/ServerInstall,$(1),owftpd,80)
+       $(call Package/owfs-server/Install,$(1),owftpd,80)
 endef
 
 
 define Package/libow/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libow-*.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libow-*.so.* $(1)/usr/lib/
 endef
 
 define Package/libow-capi/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libowcapi-*.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libowcapi-*.so.* $(1)/usr/lib/
        #$(INSTALL_DIR) $(1)/usr/include
        #$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/include/{owcapi,owfs_config}.h $(1)/usr/include/
 endef
 
-define Package/libow-perl/install
-       install -d -m0755 $(1)/usr/lib/perl5
-       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/perl5/* $(1)/usr/lib/perl5
-       -rm -f $(1)/usr/lib/perl5/*/perllocal.pod
-endef
-
 
 $(eval $(call BuildPackage,owfs))
 $(eval $(call BuildPackage,owshell))
@@ -255,4 +272,3 @@ $(eval $(call BuildPackage,owftpd))
 
 $(eval $(call BuildPackage,libow))
 $(eval $(call BuildPackage,libow-capi))
-$(eval $(call BuildPackage,libow-perl))