[packages] bash: force linking against internal libreadline.a, fixes Backfire build...
[openwrt/svn-archive/archive.git] / utils / pciutils / Makefile
index a4d534fae5d3de17129818ad7d6628d08af0a4f4..31f7a0289a392ed707bc692bca9efb171e38bf68 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
-PKG_VERSION:=3.1.6
-PKG_RELEASE:=1
+PKG_VERSION:=3.1.7
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
-PKG_MD5SUM:=1d183851f68abd6c918a5c1852576ad6
+PKG_MD5SUM:=35222edb86b50a6641352c66fe829b2e
 
 PKG_INSTALL:=1
 
@@ -34,7 +34,8 @@ endef
 
 define Package/pciutils/postinst
 #!/bin/sh
-(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-pciids)
+[ -z "$${IPKG_INSTROOT}" ] || \
+(cd $${PKG_ROOT}/usr/share; $${PKG_ROOT}/usr/sbin/update-pciids; rm pci.ids.gz.old)
 exit 0
 endef
 
@@ -44,6 +45,10 @@ MAKE_FLAGS += \
        HOST="$(GNU_TARGET_NAME)" \
        ZLIB="yes" \
 
+ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
+TARGET_LDFLAGS += -lresolv
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib