coreutils: fix a few failed configure tests
[openwrt/svn-archive/archive.git] / utils / psplash / Makefile
index 72185d216ecc9d3258b165fde81bf6f20cdf5451..0426cb8c9067776381596b3273de5d37d344c9f6 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,31 +15,42 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://projects.o-hand.com/sources/psplash/
 PKG_MD5SUM:=7649b7e0fac573eca2048a2a267e242b
 
+PKG_INSTALL:=1
+
+IMAGE_FILE:=generic
+ifeq ($(CONFIG_TARGET_s3c24xx),y)
+  IMAGE_FILE:=480x640
+endif
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/psplash
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6_X86
+  DEPENDS:=@LINUX_2_6
   TITLE:=A boot splash screen
-  DESCRIPTION:=PSplash is a userspace graphical boot splash screen.
   URL:=http://projects.o-hand.com/psplash
 endef
 
+define Package/psplash/description
+PSplash is a userspace graphical boot splash screen.
+endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Build/Configure
+       $(CP) \
+               ./files/image_$(IMAGE_FILE).h \
+               $(PKG_BUILD_DIR)/psplash-owrt-img.h
+       $(call Build/Configure/Default)
 endef
 
 define Package/psplash/install
-       $(INSTALL_DIR) $(1)/bin
+       $(INSTALL_DIR) $(1)/bin $(1)/etc/init.d
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/bin/psplash \
-               $(PKG_INSTALL_DIR)/usr/bin/psplash-write \
+               $(PKG_INSTALL_DIR)/usr/bin/psplash* \
                $(1)/bin/
+       $(INSTALL_BIN) \
+               ./files/init \
+               $(1)/etc/init.d/psplash
 endef
 
-
 $(eval $(call BuildPackage,psplash))