[net] elinks: Moved elinks to main list and removed Web submenu, as it elinks was...
[openwrt/svn-archive/archive.git] / utils / pwgen / Makefile
index d4a9481c6702ed6c171f5093fa984ca620e01f24..84e40c6ca69e4c089a2e6bd1963fdb5b9e9e3d3b 100644 (file)
@@ -4,20 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pwgen
-PKG_VERSION:=2.05
+PKG_VERSION:=2.06
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/pwgen
-PKG_MD5SUM:=b94546a346cb352054ea2d3d09f7f885
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=935aebcbe610fbc9de8125e7b7d71297
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,18 +21,20 @@ define Package/pwgen
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Automatic Password generator
-  DESCRIPTION:=\
-       pwgen generates random, meaningless but pronounceable passwords. \\\
-       These passwords contain either only lowercase letters, or upper \\\
-       and lower case mixed, or digits thrown in. \\\
-       Uppercase letters and digits are placed in a way that eases \\\
-       remembering their position when memorizing only the word. \\\
-       \\\
-       E.g. to generate a WPA preshared-key do: \\\
-           pwgen -c -n -s 63 1
   URL:=http://sourceforge.net/projects/pwgen/
 endef
 
+define Package/pwgen/description
+       pwgen generates random, meaningless but pronounceable passwords.
+       These passwords contain either only lowercase letters, or upper
+       and lower case mixed, or digits thrown in.
+       Uppercase letters and digits are placed in a way that eases
+       remembering their position when memorizing only the word.
+
+       E.g. to generate a WPA preshared-key do:
+       pwgen -c -n -s 63 1
+endef
+
 # uses GNU configure
 
 define Package/pwgen/install