python packaging related cleanups for rdiff-backup and rrdtool
[openwrt/svn-archive/archive.git] / utils / rdiff-backup / Makefile
index 4172ade554698ba02765ef7f6cb2e99ffbdbb0e1..5a2fc01dcd7bf383cb8674b50b78cd3e47e22f6d 100644 (file)
@@ -20,9 +20,6 @@ PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
 -include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
-ifneq ($(MAKECMDGOALS),download)
-  $(if $(DUMP)$(Build/Compile/PyMod),,$(error Python packaging code not found.))
-endif
 
 define Package/rdiff-backup
   SUBMENU:=Python
@@ -48,6 +45,7 @@ define PyPackage/rdiff-backup/filespec
 endef
 
 define Build/Compile
+       $(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
        $(call Build/Compile/PyMod,., \
                build --librsync-dir="$(STAGING_DIR)/usr" , \
        )