[net] printing: Removed printing submenu as it had only two entries.
[openwrt/svn-archive/archive.git] / utils / screen / Makefile
index 6b1b5ac969f372c28c72730fe9c87f8f0ef80d87..97a53b6de494383cf768d4dc9b74cc40229acfbb 100644 (file)
@@ -4,21 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=screen
-PKG_VERSION:=4.0.2
-PKG_RELEASE:=1
-PKG_MD5SUM:=ed68ea9b43d9fba0972cb017a24940a1
+PKG_VERSION:=4.0.3
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=@GNU/screen
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=ftp://ftp.uni-erlangen.de/pub/utilities/screen \
+       @GNU/screen
+PKG_MD5SUM:=8506fd205028a96c741e4037de6e3c42
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,49 +23,26 @@ define Package/screen
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=Full-screen terminal window manager
-  DESCRIPTION:=Screen is a full-screen window manager that multiplexes a physical\\\
-       terminal between several processes, typically interactive shells.\\\
   URL:=http://www.gnu.org/software/screen/
 endef
 
-define Build/Configure 
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib \
-                 --localstatedir=/var \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --enable-shared \
-                 --disable-static \
-       );
+define Package/screen/description
+       Screen is a full-screen window manager that multiplexes a physical
+       terminal between several processes, typically interactive shells.
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR)
+define Build/Configure
+       $(call Build/Configure/Default,\
+               --with-sys-screenrc=/etc/screenrc,\
+               LIBS="-lcrypt" \
+       )
 endef
 
 define Package/screen/install  
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/screen $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/screen $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/etc/screenrc $(1)/etc/screenrc
 endef
 
 $(eval $(call BuildPackage,screen))