[package] ruby: fix path to libiconv
[openwrt/svn-archive/archive.git] / utils / setserial / Makefile
index 1a2fe7a2a68bc1da5fa194bdb1e0164e66aed8ea..c529f1fc5299a2ec90662d5691d5cc422a891f43 100644 (file)
@@ -1,10 +1,9 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,8 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/setserial
 PKG_MD5SUM:=c4867d72c41564318e0107745eb7a0f2
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/setserial
@@ -25,6 +22,7 @@ define Package/setserial
   CATEGORY:=Utilities
   TITLE:=Serial port configuration utility
   URL:=http://setserial.sourceforge.net/
+  SUBMENU:=Terminal
 endef
 
 define Package/setserial/description
@@ -39,7 +37,7 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               all
+               setserial
 endef
 
 define Package/setserial/install