[packages] tcpdump: properly handle iface names with leading digits (#7572)
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index 479cfe473ad38e880404cc915b3a7c9e2251bf3a..07b41525b5206bb017f4279537ba4e095ee8eb1b 100644 (file)
@@ -4,41 +4,44 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
-PKG_VERSION:=5.36
+PKG_VERSION:=5.38
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
-PKG_MD5SUM:=2e424f2d35efa38a29ebca419c1dbe3c
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=a282846532ecbd6b4a28072373b3a70b
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/smartmontools
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=+uclibcxx
   TITLE:=S.M.A.R.T Monitoring Tool
-  DESCRIPTION:=\
-       smartmontools contains utility programs (smartctl, smartd) to \\\
-       control/monitor storage systems using the Self-Monitoring, Analysis \\\
-       and Reporting Technology System (S.M.A.R.T.) built into most modern \\\
-       ATA and SCSI disks. It is derived from smartsuite.
   URL:=http://smartmontools.sourceforge.net/
 endef
 
+define Package/smartmontools/description
+       smartmontools contains utility programs (smartctl, smartd) to
+       control/monitor storage systems using the Self-Monitoring, Analysis
+       and Reporting Technology System (S.M.A.R.T.) built into most modern
+       ATA and SCSI disks. It is derived from smartsuite.
+endef
+
 # uses GNU configure
 
 define Build/Configure 
        (cd $(PKG_BUILD_DIR); ./autogen.sh );
        $(call Build/Configure/Default,, \
-       ac_libc_have_working_snprintf=yes \
+               ac_libc_have_working_snprintf=yes \
+               CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
+               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
+               LDFLAGS="$$$$LDFLAGS" \
+               LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
        )
 endef
 
@@ -54,7 +57,7 @@ define Package/smartmontools/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/smartd.conf $(1)/etc
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/smartd.init $(1)/etc/init.d/smartd
+       $(INSTALL_BIN) ./files/smartd.init $(1)/etc/init.d/smartd
 endef
 
 $(eval $(call BuildPackage,smartmontools))