[packages] ruby: add dependency on ruby-core to ruby-irb (closes: #5112)
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index cc3ac6f0a5869cdfdf3d044560448207c98f918b..0e9955503e2d3839ae00c3167f64f5d3e58af9db 100644 (file)
@@ -9,29 +9,27 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
-PKG_VERSION:=5.37
-PKG_RELEASE:=2
+PKG_VERSION:=5.38
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
-PKG_MD5SUM:=4ab3668b7d1362ce923f64a211e0e568
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=a282846532ecbd6b4a28072373b3a70b
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/smartmontools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libstdcpp
+  DEPENDS:=+uclibcxx
   TITLE:=S.M.A.R.T Monitoring Tool
   URL:=http://smartmontools.sourceforge.net/
 endef
 
 define Package/smartmontools/description
-       smartmontools contains utility programs (smartctl, smartd) to 
-       control/monitor storage systems using the Self-Monitoring, Analysis 
-       and Reporting Technology System (S.M.A.R.T.) built into most modern 
+       smartmontools contains utility programs (smartctl, smartd) to
+       control/monitor storage systems using the Self-Monitoring, Analysis
+       and Reporting Technology System (S.M.A.R.T.) built into most modern
        ATA and SCSI disks. It is derived from smartsuite.
 endef
 
@@ -40,7 +38,11 @@ endef
 define Build/Configure 
        (cd $(PKG_BUILD_DIR); ./autogen.sh );
        $(call Build/Configure/Default,, \
-       ac_libc_have_working_snprintf=yes \
+               ac_libc_have_working_snprintf=yes \
+               CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
+               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
+               LDFLAGS="$$$$LDFLAGS" \
+               LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
        )
 endef