Fix glib2 build and increase package version number.
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index c35d2d71b246134778f52ab50df7da0d77a4b58d..574894cd8f8f04f264ec99b69f3b26a2685efc50 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
-PKG_VERSION:=5.37
+PKG_VERSION:=5.38
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
-PKG_MD5SUM:=4ab3668b7d1362ce923f64a211e0e568
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=a282846532ecbd6b4a28072373b3a70b
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,14 +23,16 @@ define Package/smartmontools
   CATEGORY:=Utilities
   DEPENDS:=+libstdcpp
   TITLE:=S.M.A.R.T Monitoring Tool
-  DESCRIPTION:=\
-       smartmontools contains utility programs (smartctl, smartd) to \\\
-       control/monitor storage systems using the Self-Monitoring, Analysis \\\
-       and Reporting Technology System (S.M.A.R.T.) built into most modern \\\
-       ATA and SCSI disks. It is derived from smartsuite.
   URL:=http://smartmontools.sourceforge.net/
 endef
 
+define Package/smartmontools/description
+       smartmontools contains utility programs (smartctl, smartd) to
+       control/monitor storage systems using the Self-Monitoring, Analysis
+       and Reporting Technology System (S.M.A.R.T.) built into most modern
+       ATA and SCSI disks. It is derived from smartsuite.
+endef
+
 # uses GNU configure
 
 define Build/Configure 
@@ -55,11 +54,7 @@ define Package/smartmontools/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/smartd.conf $(1)/etc
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/smartd.init $(1)/etc/init.d/smartd
+       $(INSTALL_BIN) ./files/smartd.init $(1)/etc/init.d/smartd
 endef
 
 $(eval $(call BuildPackage,smartmontools))
-
-$(eval $(call RequireCommand,automake, \
-       $(PKG_NAME) requires automake. \
-))