[packages] usb-modeswitch: update to v1.0.7 (#6522)
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index c85fa1134d61db807249a2dca4f82dd8b2804984..031b60f05ef59ad1094d92300fa0e37124e11422 100644 (file)
@@ -1,23 +1,28 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.5.11
 PKG_RELEASE:=1
-PKG_MD5SUM:=28335e15c83456a3db055a0a0efcb4fe
 
-PKG_SOURCE_URL:=@SF/strace
+ifeq ($(CONFIG_LINUX_2_6_25),y) 
+  PKG_VERSION:=4.5.16
+  PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
+  PATCH_DIR:=patches-4.5.16
+else
+  PKG_VERSION:=4.5.19
+  PKG_MD5SUM:=2415e435d61e40315a298c80aced0cda
+endif
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,14 +30,13 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
-  DESCRIPTION:=A useful diagnostic, instructional, and debugging tool. \\\
-    Allows you to track what system calls a program makes while it is \\\
-    running.
   URL:=http://strace.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default)
+define Package/strace/description
+       A useful diagnostic, instructional, and debugging tool.
+       Allows you to track what system calls a program makes while it is
+       running.
 endef
 
 define Build/Compile
@@ -41,8 +45,8 @@ define Build/Compile
 endef
 
 define Package/strace/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,strace))