[packages] net/freeswitch: Remove shell-script based UCI config. It breaks on restar...
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index b3a9d90e78c8d8be40a28aee193ca6e5a5e04ca7..35f714f259183ceb9168b60778baec76dcf8bbcd 100644 (file)
@@ -1,23 +1,31 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.5.14
-PKG_RELEASE:=1
+
+ifeq ($(CONFIG_LINUX_2_6_25),y)
+  PKG_VERSION:=4.5.16
+  PKG_RELEASE:=3
+  PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
+  PATCH_DIR:=patches-4.5.16
+else
+  PKG_VERSION:=4.5.20
+  PKG_RELEASE:=1
+  PKG_MD5SUM:=64dfe10d9db0c1e34030891695ffca4b
+endif
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/strace
-PKG_MD5SUM:=09bcd5d00ece28f8154dec11cadfce3c
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,23 +33,28 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
-  DESCRIPTION:=\
-       A useful diagnostic, instructional, and debugging tool. \\\
-       Allows you to track what system calls a program makes while it is \\\
-       running.
   URL:=http://strace.sourceforge.net/
 endef
 
-# uses GNU configure
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
+define Package/strace/description
+A useful diagnostic, instructional, and debugging tool. Allows you to track what
+system calls a program makes while it is running.
 endef
 
+# needed when compiling against Linux 2.4
+CONFIGURE_VARS += \
+       ac_cv_header_linux_netlink_h=yes
+
+ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  TARGET_CPPFLAGS += -I$(LINUX_DIR)/include
+endif
+
+MAKE_FLAGS := \
+       CCOPT="$(TARGET_CFLAGS)"
+
 define Package/strace/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,strace))