[packages] net/freeswitch: Remove shell-script based UCI config. It breaks on restar...
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index e73a25290c318c2ca8de29e01b83d7b55d96c6ad..35f714f259183ceb9168b60778baec76dcf8bbcd 100644 (file)
@@ -1,29 +1,31 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-PKG_RELEASE:=2
 
-ifneq ($(CONFIG_LINUX_2_6_27),y)
+ifeq ($(CONFIG_LINUX_2_6_25),y)
   PKG_VERSION:=4.5.16
+  PKG_RELEASE:=3
   PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
+  PATCH_DIR:=patches-4.5.16
 else
-  PKG_VERSION:=4.5.18
-  PKG_MD5SUM:=e9449fcee97e6a8ed73934c883c870e0
-  PATCH_DIR:=./none
+  PKG_VERSION:=4.5.20
+  PKG_RELEASE:=1
+  PKG_MD5SUM:=64dfe10d9db0c1e34030891695ffca4b
 endif
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,19 +37,24 @@ define Package/strace
 endef
 
 define Package/strace/description
-       A useful diagnostic, instructional, and debugging tool.
-       Allows you to track what system calls a program makes while it is
-       running.
+A useful diagnostic, instructional, and debugging tool. Allows you to track what
+system calls a program makes while it is running.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
-endef
+# needed when compiling against Linux 2.4
+CONFIGURE_VARS += \
+       ac_cv_header_linux_netlink_h=yes
+
+ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  TARGET_CPPFLAGS += -I$(LINUX_DIR)/include
+endif
+
+MAKE_FLAGS := \
+       CCOPT="$(TARGET_CFLAGS)"
 
 define Package/strace/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,strace))