[package] update gpsd to 2.94, add config, init and hotplug scripts, patch from Rober...
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index 95282459fb8d196fda72f211e09fadd0fd9ffec8..35f714f259183ceb9168b60778baec76dcf8bbcd 100644 (file)
@@ -9,31 +9,26 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-PKG_RELEASE:=3
 
-OLD_KERNEL=$(findstring y,$(foreach v,21 25,$(CONFIG_LINUX_2_6_$(v))))
-ifneq ($(OLD_KERNEL),)
+ifeq ($(CONFIG_LINUX_2_6_25),y)
   PKG_VERSION:=4.5.16
+  PKG_RELEASE:=3
   PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
   PATCH_DIR:=patches-4.5.16
 else
-  PKG_VERSION:=4.5.19
-  PKG_MD5SUM:=2415e435d61e40315a298c80aced0cda
+  PKG_VERSION:=4.5.20
+  PKG_RELEASE:=1
+  PKG_MD5SUM:=64dfe10d9db0c1e34030891695ffca4b
 endif
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-CONFIGURE_VARS += \
-       ac_cv_header_linux_netlink_h=yes
-
-TARGET_CFLAGS += \
-       -I$(LINUX_DIR)/include
-
 define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
@@ -46,9 +41,17 @@ A useful diagnostic, instructional, and debugging tool. Allows you to track what
 system calls a program makes while it is running.
 endef
 
+# needed when compiling against Linux 2.4
 CONFIGURE_VARS += \
        ac_cv_header_linux_netlink_h=yes
 
+ifneq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  TARGET_CPPFLAGS += -I$(LINUX_DIR)/include
+endif
+
+MAKE_FLAGS := \
+       CCOPT="$(TARGET_CFLAGS)"
+
 define Package/strace/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/