Merge pull request #4853 from StevenHessing/noddos
[feed/packages.git] / utils / tar / Makefile
index d8295d80845572cfb92ada1305f2a23ed970e12c..bae2adcd4c2a1abc515ed8fa59e913df640a1b7c 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tar
 PKG_VERSION:=1.29
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=955cd533955acb1804b83fd70218da51
+PKG_HASH:=236b11190c0a3a6885bdb8d61424f2b36a5872869aa3f7f695dea4b4843ae2f2
 PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 
 PKG_LICENSE:=GPL-3.0
@@ -21,7 +21,7 @@ PKG_LICENSE_FILES:=COPYING
 
 PKG_INSTALL:=1
 
-BUILD_DEPENDS:=xz
+PKG_BUILD_DEPENDS:=xz
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,27 +36,31 @@ define Package/tar
 endef
 
 define Package/tar/config
-       config PACKAGE_TAR_POSIX_ACL
-       bool "tar: Enable POSIX ACL support" if PACKAGE_tar
-       default n
-
-       config PACKAGE_TAR_XATTR
-       bool "tar: Enable extended attribute (xattr) support" if PACKAGE_tar
-       default n
-
-       config PACKAGE_TAR_GZIP
-       bool "tar: Enable seamless gzip support" if PACKAGE_tar
-       default y
-
-       config PACKAGE_TAR_BZIP2
-       bool "tar: Enable seamless bzip2 support" if PACKAGE_tar
-       default y
-
-       config PACKAGE_TAR_XZ
-       bool "tar: Enable seamless xz support" if PACKAGE_tar
-       select PACKAGE_xz-utils
-       select PACKAGE_xz
-       default y
+       if PACKAGE_tar
+               config PACKAGE_TAR_POSIX_ACL
+                       bool "tar: Enable POSIX ACL support"
+                       default y if USE_FS_ACL_ATTR
+                       default n
+
+               config PACKAGE_TAR_XATTR
+                       bool "tar: Enable extended attribute (xattr) support"
+                       default y if USE_FS_ACL_ATTR
+                       default n
+
+               config PACKAGE_TAR_GZIP
+                       bool "tar: Enable seamless gzip support"
+                       default y
+
+               config PACKAGE_TAR_BZIP2
+                       bool "tar: Enable seamless bzip2 support"
+                       default y
+
+               config PACKAGE_TAR_XZ
+                       bool "tar: Enable seamless xz support"
+                       select PACKAGE_xz-utils
+                       select PACKAGE_xz
+                       default y
+       endif
 endef
 
 define Package/tar/description