Merge pull request #19372 from cotequeiroz/libgd
[feed/packages.git] / utils / telldus-core / Makefile
index f7e46fc693d849c588ecedcc8bb8fb687faab157..028d6ff9f39a0f01a1f30e5341d2d9588c117b55 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=telldus-core
 PKG_VERSION:=2.1.2
-PKG_RELEASE:=6
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.telldus.com/TellStick/Software/telldus-core/
@@ -18,12 +18,23 @@ PKG_LICENSE:=LGPL-2.1-or-later
 PKG_LICENSE_FILES:=LICENSE
 
 CMAKE_INSTALL:=1
-PKG_BUILD_PARALLEL:=0
-PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
+PKG_BUILD_DEPENDS:=argp-standalone
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
+define Download/argp-cmake
+       URL:=@GITHUB/alehaa/CMake-argp/e7e77e68d062708edf055f944d3094b0ce0b11b8/cmake
+       FILE:=Findargp.cmake
+       HASH:=b74e961260d17bc9af868be59053e50739dc94e06cbe73e3fced414a070a29fd
+endef
+
+define Build/Prepare
+       $(eval $(call Download,argp-cmake))
+       $(Build/Prepare/Default)
+       $(CP) $(DL_DIR)/Findargp.cmake $(PKG_BUILD_DIR)/cmake/
+endef
+
 define Package/telldus-core
        SECTION:=utils
        CATEGORY:=Utilities