bluez-utils: Fixed typo in config file example dund pppopts
[openwrt/svn-archive/archive.git] / utils / usbutils / Makefile
index 0b3f2d95a5d49ea1fed294f2d234d873234646bd..098f32bd60add48477a70ed49eebb2bc8de70041 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,34 +9,35 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usbutils
-PKG_VERSION:=0.71
+PKG_VERSION:=0.73
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-usb
-PKG_MD5SUM:=479d7c7098ef44cc95e7978fd71c712c
-PKG_CAT:=zcat
+PKG_MD5SUM:=88978b4ad891f610620b1b8e5e0f43eb
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
+PKG_BUILD_DEPENDS:=zlib
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/usbutils
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libusb
+  DEPENDS:=+libusb +zlib
   TITLE:=USB devices listing utilities
   URL:=http://linux-usb.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
+define Package/usbutils/postinst
+#!/bin/sh
+$${IPKG_INSTROOT}/usr/sbin/update-usbids.sh
 endef
 
+# uses GNU configure
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -44,10 +45,11 @@ define Build/Compile
 endef
 
 define Package/usbutils/install
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/share
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/usb.ids $(1)/usr/share/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/update-usbids.sh $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/share
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/usb.ids.gz $(1)/usr/share/
 endef
 
 $(eval $(call BuildPackage,usbutils))