xfconf: use official download mirror
[openwrt/svn-archive/feeds.git] / xfce / app / xfconf / Makefile
index 4b4351c207d85509e8f74f5443f6cd438e36d6df..5e21259e799dfa3ad18cbf77601a041a614f7010 100644 (file)
@@ -1,32 +1,29 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xfconf
-PKG_VERSION:=4.6.0
+PKG_VERSION:=4.6.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.tx-us.xfce.org/archive/xfce-$(PKG_VERSION)/src/
-PKG_MD5SUM:=38595f78379eb1f456e97b393fdafd20
+PKG_SOURCE_URL:=http://archive.xfce.org/src/xfce/xfconf/4.6
+PKG_MD5SUM:=d4d3018767ea9eb4b57cc57d4038023b
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
-
-TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include/
+include $(INCLUDE_DIR)/nls.mk
 
 TARGET_LDFLAGS+= \
        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-       -Wl,-rpath=/usr/lib \
-       -L$(STAGING_DIR)/usr/lib/libintl/lib
+       -Wl,-rpath=/usr/lib
 
 define Package/libxfconf
   SECTION:=xorg-app