ipq40xx: 6.6: refresh kernel patches
authorChristian Marangi <ansuelsmth@gmail.com>
Wed, 20 Mar 2024 10:27:10 +0000 (11:27 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 2 Apr 2024 21:45:20 +0000 (23:45 +0200)
Refresh kernel patches using make target/linux/refresh.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
16 files changed:
target/linux/ipq40xx/patches-6.6/004-v6.7-firmware-qcom_scm-disable-SDI-if-required.patch
target/linux/ipq40xx/patches-6.6/104-clk-fix-apss-cpu-overclocking.patch
target/linux/ipq40xx/patches-6.6/110-mtd-limit-OTP-nvmem-to-non-nand-devices.patch
target/linux/ipq40xx/patches-6.6/400-mmc-sdhci-sdhci-msm-use-sdhci_set_clock-instead-of-s.patch
target/linux/ipq40xx/patches-6.6/401-mmc-sdhci-msm-comment-unused-sdhci_msm_set_clock.patch
target/linux/ipq40xx/patches-6.6/422-firmware-qcom-scm-fix-SCM-cold-boot-address.patch
target/linux/ipq40xx/patches-6.6/700-net-ipqess-introduce-the-Qualcomm-IPQESS-driver.patch
target/linux/ipq40xx/patches-6.6/701-net-dsa-add-out-of-band-tagging-protocol.patch
target/linux/ipq40xx/patches-6.6/702-net-ipqess-Add-out-of-band-DSA-tagging-support.patch
target/linux/ipq40xx/patches-6.6/705-ARM-dts-qcom-ipq4019-Add-description-for-the-IPQESS-.patch
target/linux/ipq40xx/patches-6.6/706-net-dsa-qca8k-add-IPQ4019-built-in-switch-support.patch
target/linux/ipq40xx/patches-6.6/707-arm-dts-ipq4019-add-switch-node.patch
target/linux/ipq40xx/patches-6.6/709-ARM-dts-qcom-ipq4019-add-QCA8075-PHY-Package-nodes.patch
target/linux/ipq40xx/patches-6.6/710-arm-dts-ipq4019-QCA807x-properties.patch
target/linux/ipq40xx/patches-6.6/850-soc-add-qualcomm-syscon.patch
target/linux/ipq40xx/patches-6.6/910-Revert-firmware-qcom_scm-Clear-download-bit-during-r.patch

index ae7e9f97c07657829830b90d4c40f39f62cba546..a296d8c9a2d13e007e36da2d19ff18bec2607d02 100644 (file)
@@ -27,9 +27,9 @@ Signed-off-by: Bjorn Andersson <andersson@kernel.org>
 
 --- a/drivers/firmware/qcom_scm.c
 +++ b/drivers/firmware/qcom_scm.c
 
 --- a/drivers/firmware/qcom_scm.c
 +++ b/drivers/firmware/qcom_scm.c
-@@ -407,6 +407,29 @@ int qcom_scm_set_remote_state(u32 state,
+@@ -410,6 +410,29 @@ int qcom_scm_set_remote_state(u32 state,
  }
  }
- EXPORT_SYMBOL(qcom_scm_set_remote_state);
+ EXPORT_SYMBOL_GPL(qcom_scm_set_remote_state);
  
 +static int qcom_scm_disable_sdi(void)
 +{
  
 +static int qcom_scm_disable_sdi(void)
 +{
@@ -57,7 +57,7 @@ Signed-off-by: Bjorn Andersson <andersson@kernel.org>
  static int __qcom_scm_set_dload_mode(struct device *dev, bool enable)
  {
        struct qcom_scm_desc desc = {
  static int __qcom_scm_set_dload_mode(struct device *dev, bool enable)
  {
        struct qcom_scm_desc desc = {
-@@ -1411,6 +1434,13 @@ static int qcom_scm_probe(struct platfor
+@@ -1467,6 +1490,13 @@ static int qcom_scm_probe(struct platfor
  
        __get_convention();
  
  
        __get_convention();
  
@@ -73,7 +73,7 @@ Signed-off-by: Bjorn Andersson <andersson@kernel.org>
         * will cause the boot stages to enter download mode, unless
 --- a/drivers/firmware/qcom_scm.h
 +++ b/drivers/firmware/qcom_scm.h
         * will cause the boot stages to enter download mode, unless
 --- a/drivers/firmware/qcom_scm.h
 +++ b/drivers/firmware/qcom_scm.h
-@@ -77,6 +77,7 @@ extern int scm_legacy_call(struct device
+@@ -80,6 +80,7 @@ extern int scm_legacy_call(struct device
  #define QCOM_SCM_SVC_BOOT             0x01
  #define QCOM_SCM_BOOT_SET_ADDR                0x01
  #define QCOM_SCM_BOOT_TERMINATE_PC    0x02
  #define QCOM_SCM_SVC_BOOT             0x01
  #define QCOM_SCM_BOOT_SET_ADDR                0x01
  #define QCOM_SCM_BOOT_TERMINATE_PC    0x02
index 2de03f7ae0aff2cc2ba59108fb3c09fd843be02a..a2d9fac1ec249ba4b63fad48e6c3803a1095a2c3 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/clk/qcom/gcc-ipq4019.c
 +++ b/drivers/clk/qcom/gcc-ipq4019.c
 
 --- a/drivers/clk/qcom/gcc-ipq4019.c
 +++ b/drivers/clk/qcom/gcc-ipq4019.c
-@@ -1243,6 +1243,29 @@ static const struct clk_fepll_vco gcc_fe
+@@ -120,6 +120,29 @@ static const struct clk_fepll_vco gcc_fe
        .reg = 0x2f020,
  };
  
        .reg = 0x2f020,
  };
  
@@ -74,7 +74,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
  /*
   * Round rate function for APSS CPU PLL Clock divider.
   * It looks up the frequency table and returns the next higher frequency
  /*
   * Round rate function for APSS CPU PLL Clock divider.
   * It looks up the frequency table and returns the next higher frequency
-@@ -1255,7 +1278,7 @@ static long clk_cpu_div_round_rate(struc
+@@ -132,7 +155,7 @@ static long clk_cpu_div_round_rate(struc
        struct clk_hw *p_hw;
        const struct freq_tbl *f;
  
        struct clk_hw *p_hw;
        const struct freq_tbl *f;
  
@@ -83,7 +83,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        if (!f)
                return -EINVAL;
  
        if (!f)
                return -EINVAL;
  
-@@ -1277,7 +1300,7 @@ static int clk_cpu_div_set_rate(struct c
+@@ -154,7 +177,7 @@ static int clk_cpu_div_set_rate(struct c
        const struct freq_tbl *f;
        u32 mask;
  
        const struct freq_tbl *f;
        u32 mask;
  
@@ -92,7 +92,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        if (!f)
                return -EINVAL;
  
        if (!f)
                return -EINVAL;
  
-@@ -1304,6 +1327,7 @@ static unsigned long
+@@ -181,6 +204,7 @@ static unsigned long
  clk_cpu_div_recalc_rate(struct clk_hw *hw,
                        unsigned long parent_rate)
  {
  clk_cpu_div_recalc_rate(struct clk_hw *hw,
                        unsigned long parent_rate)
  {
@@ -100,7 +100,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
        struct clk_fepll *pll = to_clk_fepll(hw);
        u32 cdiv, pre_div;
        u64 rate;
        struct clk_fepll *pll = to_clk_fepll(hw);
        u32 cdiv, pre_div;
        u64 rate;
-@@ -1324,7 +1348,11 @@ clk_cpu_div_recalc_rate(struct clk_hw *h
+@@ -201,7 +225,11 @@ clk_cpu_div_recalc_rate(struct clk_hw *h
        rate = clk_fepll_vco_calc_rate(pll, parent_rate) * 2;
        do_div(rate, pre_div);
  
        rate = clk_fepll_vco_calc_rate(pll, parent_rate) * 2;
        do_div(rate, pre_div);
  
index 80fd20318bfd9417cf8185e698d132beb3fe8069..03f45d7a9a23cfb579c1689356e645a12270aaec 100644 (file)
@@ -45,11 +45,9 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  drivers/mtd/mtdcore.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
  drivers/mtd/mtdcore.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/drivers/mtd/mtdcore.c b/drivers/mtd/mtdcore.c
-index 5887feb347a4..6872477a5129 100644
 --- a/drivers/mtd/mtdcore.c
 +++ b/drivers/mtd/mtdcore.c
 --- a/drivers/mtd/mtdcore.c
 +++ b/drivers/mtd/mtdcore.c
-@@ -900,7 +900,7 @@ static struct nvmem_device *mtd_otp_nvmem_register(struct mtd_info *mtd,
+@@ -933,7 +933,7 @@ static struct nvmem_device *mtd_otp_nvme
        config.name = compatible;
        config.id = NVMEM_DEVID_AUTO;
        config.owner = THIS_MODULE;
        config.name = compatible;
        config.id = NVMEM_DEVID_AUTO;
        config.owner = THIS_MODULE;
@@ -58,6 +56,3 @@ index 5887feb347a4..6872477a5129 100644
        config.type = NVMEM_TYPE_OTP;
        config.root_only = true;
        config.ignore_wp = true;
        config.type = NVMEM_TYPE_OTP;
        config.root_only = true;
        config.ignore_wp = true;
--- 
-2.43.0
-
index 9ce68d40aa14551bfd5b81e4cea049a3d2dae007..1c156d4398a41f9ac24c0b8e467bc06bd04feb31 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/mmc/host/sdhci-msm.c
 +++ b/drivers/mmc/host/sdhci-msm.c
 
 --- a/drivers/mmc/host/sdhci-msm.c
 +++ b/drivers/mmc/host/sdhci-msm.c
-@@ -2451,7 +2451,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
+@@ -2320,7 +2320,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
  
  static const struct sdhci_ops sdhci_msm_ops = {
        .reset = sdhci_and_cqhci_reset,
  
  static const struct sdhci_ops sdhci_msm_ops = {
        .reset = sdhci_and_cqhci_reset,
index b297600171a8c65576d09be35ee05eb0bf54495e..cfbb6439748b6d2f17e3e6f6fe4a3689ffb50699 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
 
 --- a/drivers/mmc/host/sdhci-msm.c
 +++ b/drivers/mmc/host/sdhci-msm.c
 
 --- a/drivers/mmc/host/sdhci-msm.c
 +++ b/drivers/mmc/host/sdhci-msm.c
-@@ -1751,49 +1751,49 @@ static unsigned int sdhci_msm_get_min_cl
+@@ -1755,49 +1755,49 @@ static unsigned int sdhci_msm_get_min_cl
        return SDHCI_MSM_MIN_CLOCK;
  }
  
        return SDHCI_MSM_MIN_CLOCK;
  }
  
index cb06ff353c7cb7d35c4c378a171d5af000dcc047..1c8cfb298115b4cba473e47b609e9b18cc67f46b 100644 (file)
@@ -118,7 +118,7 @@ Signed-off-by: Brian Norris <computersforpeace@gmail.com>
  }
 --- a/drivers/firmware/qcom_scm.c
 +++ b/drivers/firmware/qcom_scm.c
  }
 --- a/drivers/firmware/qcom_scm.c
 +++ b/drivers/firmware/qcom_scm.c
-@@ -312,6 +312,17 @@ static int qcom_scm_set_boot_addr(void *
+@@ -315,6 +315,17 @@ static int qcom_scm_set_boot_addr(void *
        desc.args[0] = flags;
        desc.args[1] = virt_to_phys(entry);
  
        desc.args[0] = flags;
        desc.args[1] = virt_to_phys(entry);
  
index be12bfcd2137d471cef7be0625889ef3567776db..a15efe57d8e91e73625b184ec42f68fb2a6c0cc7 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17075,6 +17075,13 @@ L:    netdev@vger.kernel.org
+@@ -17708,6 +17708,13 @@ L:    netdev@vger.kernel.org
  S:    Maintained
  F:    drivers/net/ethernet/qualcomm/emac/
  
  S:    Maintained
  F:    drivers/net/ethernet/qualcomm/emac/
  
@@ -48,7 +48,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  R:    Bhupesh Sharma <bhupesh.sharma@linaro.org>
 --- a/drivers/net/ethernet/qualcomm/Kconfig
 +++ b/drivers/net/ethernet/qualcomm/Kconfig
  R:    Bhupesh Sharma <bhupesh.sharma@linaro.org>
 --- a/drivers/net/ethernet/qualcomm/Kconfig
 +++ b/drivers/net/ethernet/qualcomm/Kconfig
-@@ -60,6 +60,17 @@ config QCOM_EMAC
+@@ -61,6 +61,17 @@ config QCOM_EMAC
          low power, Receive-Side Scaling (RSS), and IEEE 1588-2008
          Precision Clock Synchronization Protocol.
  
          low power, Receive-Side Scaling (RSS), and IEEE 1588-2008
          Precision Clock Synchronization Protocol.
  
index 6ed6fa75407fca24f3ddc3d81a115dca052eee76..e07cee30c70f9c07ce0e9888902eb69b220c40b6 100644 (file)
@@ -64,7 +64,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
  
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -17081,6 +17081,7 @@ L:     netdev@vger.kernel.org
+@@ -17714,6 +17714,7 @@ L:     netdev@vger.kernel.org
  S:    Maintained
  F:    Documentation/devicetree/bindings/net/qcom,ipq4019-ess-edma.yaml
  F:    drivers/net/ethernet/qualcomm/ipqess/
  S:    Maintained
  F:    Documentation/devicetree/bindings/net/qcom,ipq4019-ess-edma.yaml
  F:    drivers/net/ethernet/qualcomm/ipqess/
@@ -93,7 +93,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
 +#endif
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
 +#endif
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -4588,6 +4588,9 @@ enum skb_ext_id {
+@@ -4627,6 +4627,9 @@ enum skb_ext_id {
  #if IS_ENABLED(CONFIG_MCTP_FLOWS)
        SKB_EXT_MCTP,
  #endif
  #if IS_ENABLED(CONFIG_MCTP_FLOWS)
        SKB_EXT_MCTP,
  #endif
@@ -105,7 +105,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  
 --- a/include/net/dsa.h
 +++ b/include/net/dsa.h
  
 --- a/include/net/dsa.h
 +++ b/include/net/dsa.h
-@@ -55,6 +55,7 @@ struct phylink_link_state;
+@@ -56,6 +56,7 @@ struct phylink_link_state;
  #define DSA_TAG_PROTO_RTL8_4T_VALUE           25
  #define DSA_TAG_PROTO_RZN1_A5PSW_VALUE                26
  #define DSA_TAG_PROTO_LAN937X_VALUE           27
  #define DSA_TAG_PROTO_RTL8_4T_VALUE           25
  #define DSA_TAG_PROTO_RZN1_A5PSW_VALUE                26
  #define DSA_TAG_PROTO_LAN937X_VALUE           27
@@ -113,7 +113,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  
  enum dsa_tag_protocol {
        DSA_TAG_PROTO_NONE              = DSA_TAG_PROTO_NONE_VALUE,
  
  enum dsa_tag_protocol {
        DSA_TAG_PROTO_NONE              = DSA_TAG_PROTO_NONE_VALUE,
-@@ -85,6 +86,7 @@ enum dsa_tag_protocol {
+@@ -86,6 +87,7 @@ enum dsa_tag_protocol {
        DSA_TAG_PROTO_RTL8_4T           = DSA_TAG_PROTO_RTL8_4T_VALUE,
        DSA_TAG_PROTO_RZN1_A5PSW        = DSA_TAG_PROTO_RZN1_A5PSW_VALUE,
        DSA_TAG_PROTO_LAN937X           = DSA_TAG_PROTO_LAN937X_VALUE,
        DSA_TAG_PROTO_RTL8_4T           = DSA_TAG_PROTO_RTL8_4T_VALUE,
        DSA_TAG_PROTO_RZN1_A5PSW        = DSA_TAG_PROTO_RZN1_A5PSW_VALUE,
        DSA_TAG_PROTO_LAN937X           = DSA_TAG_PROTO_LAN937X_VALUE,
@@ -123,7 +123,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  struct dsa_switch;
 --- a/net/core/skbuff.c
 +++ b/net/core/skbuff.c
  struct dsa_switch;
 --- a/net/core/skbuff.c
 +++ b/net/core/skbuff.c
-@@ -62,8 +62,12 @@
+@@ -63,8 +63,12 @@
  #include <linux/mpls.h>
  #include <linux/kcov.h>
  #include <linux/if.h>
  #include <linux/mpls.h>
  #include <linux/kcov.h>
  #include <linux/if.h>
@@ -136,7 +136,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  #include <net/dst.h>
  #include <net/sock.h>
  #include <net/checksum.h>
  #include <net/dst.h>
  #include <net/sock.h>
  #include <net/checksum.h>
-@@ -4517,6 +4521,9 @@ static const u8 skb_ext_type_len[] = {
+@@ -4812,6 +4816,9 @@ static const u8 skb_ext_type_len[] = {
  #if IS_ENABLED(CONFIG_MCTP_FLOWS)
        [SKB_EXT_MCTP] = SKB_EXT_CHUNKSIZEOF(struct mctp_flow),
  #endif
  #if IS_ENABLED(CONFIG_MCTP_FLOWS)
        [SKB_EXT_MCTP] = SKB_EXT_CHUNKSIZEOF(struct mctp_flow),
  #endif
@@ -148,7 +148,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
  static __always_inline unsigned int skb_ext_total_length(void)
 --- a/net/dsa/Kconfig
 +++ b/net/dsa/Kconfig
  static __always_inline unsigned int skb_ext_total_length(void)
 --- a/net/dsa/Kconfig
 +++ b/net/dsa/Kconfig
-@@ -113,6 +113,15 @@ config NET_DSA_TAG_OCELOT_8021Q
+@@ -119,6 +119,15 @@ config NET_DSA_TAG_OCELOT_8021Q
          this mode, less TCAM resources (VCAP IS1, IS2, ES0) are available for
          use with tc-flower.
  
          this mode, less TCAM resources (VCAP IS1, IS2, ES0) are available for
          use with tc-flower.
  
@@ -166,8 +166,8 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
        help
 --- a/net/dsa/Makefile
 +++ b/net/dsa/Makefile
        help
 --- a/net/dsa/Makefile
 +++ b/net/dsa/Makefile
-@@ -22,6 +22,7 @@ obj-$(CONFIG_NET_DSA_TAG_LAN9303) += tag
- obj-$(CONFIG_NET_DSA_TAG_MTK) += tag_mtk.o
+@@ -31,6 +31,7 @@ obj-$(CONFIG_NET_DSA_TAG_MTK) += tag_mtk
+ obj-$(CONFIG_NET_DSA_TAG_NONE) += tag_none.o
  obj-$(CONFIG_NET_DSA_TAG_OCELOT) += tag_ocelot.o
  obj-$(CONFIG_NET_DSA_TAG_OCELOT_8021Q) += tag_ocelot_8021q.o
 +obj-$(CONFIG_NET_DSA_TAG_OOB) += tag_oob.o
  obj-$(CONFIG_NET_DSA_TAG_OCELOT) += tag_ocelot.o
  obj-$(CONFIG_NET_DSA_TAG_OCELOT_8021Q) += tag_ocelot_8021q.o
 +obj-$(CONFIG_NET_DSA_TAG_OOB) += tag_oob.o
index ac0718ba2c4a27bb3727bfbd671243bb0a3da5db..fe6b59d18f069efdbbe344f4233498edd3f5aeea 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Maxime Chevallier <maxime.chevallier@bootlin.com>
 
 --- a/drivers/net/ethernet/qualcomm/Kconfig
 +++ b/drivers/net/ethernet/qualcomm/Kconfig
 
 --- a/drivers/net/ethernet/qualcomm/Kconfig
 +++ b/drivers/net/ethernet/qualcomm/Kconfig
-@@ -64,6 +64,7 @@ config QCOM_IPQ4019_ESS_EDMA
+@@ -65,6 +65,7 @@ config QCOM_IPQ4019_ESS_EDMA
        tristate "Qualcomm Atheros IPQ4019 ESS EDMA support"
        depends on (OF && ARCH_QCOM) || COMPILE_TEST
        select PHYLINK
        tristate "Qualcomm Atheros IPQ4019 ESS EDMA support"
        depends on (OF && ARCH_QCOM) || COMPILE_TEST
        select PHYLINK
index 4f9e7f2f9a5e7d26fadf41d028dd9cc4f29f352a..6b66393d827b3234031bc432593fcf9f3dc2a476 100644 (file)
@@ -21,7 +21,7 @@ Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
-@@ -594,6 +594,54 @@
+@@ -596,6 +596,54 @@
                        status = "disabled";
                };
  
                        status = "disabled";
                };
  
index c82626eefd6bd4f122d5792fea7d51f9de325df9..e0331d28ab99345771d0ddf192221170182c4861 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/net/dsa/qca/Kconfig
 +++ b/drivers/net/dsa/qca/Kconfig
 
 --- a/drivers/net/dsa/qca/Kconfig
 +++ b/drivers/net/dsa/qca/Kconfig
-@@ -23,3 +23,11 @@ config NET_DSA_QCA8K_LEDS_SUPPORT
+@@ -24,3 +24,11 @@ config NET_DSA_QCA8K_LEDS_SUPPORT
        help
          This enabled support for LEDs present on the Qualcomm Atheros
          QCA8K Ethernet switch chips.
        help
          This enabled support for LEDs present on the Qualcomm Atheros
          QCA8K Ethernet switch chips.
index b49f08650bec0baaaa653909e53485b90be2da56..130cc52fbef89c5223845772049e626b7f33f40d 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
-@@ -594,6 +594,82 @@
+@@ -596,6 +596,82 @@
                        status = "disabled";
                };
  
                        status = "disabled";
                };
  
index afc8d920d74199801ba4a729217e5c4ad78cd694..6a37cc1f5edf151423d2aca176dc535954f039d1 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
-@@ -725,24 +725,33 @@
+@@ -727,24 +727,33 @@
                        reg = <0x90000 0x64>;
                        status = "disabled";
  
                        reg = <0x90000 0x64>;
                        status = "disabled";
  
index 2ea94d5c34e6026136aa263b97fd4f838308545c..9f4c9fa67e00676cd221649cf301738098048f6b 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 
 --- a/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
 +++ b/arch/arm/boot/dts/qcom/qcom-ipq4019.dtsi
-@@ -752,6 +752,10 @@
+@@ -754,6 +754,10 @@
                                ethphy4: ethernet-phy@4 {
                                        reg = <4>;
                                };
                                ethphy4: ethernet-phy@4 {
                                        reg = <4>;
                                };
index 80dba5d686c8f5be1a32bab96250b7e34f43531b..778b9f59303b121b6f5c33a7b14f29d955b8209f 100644 (file)
@@ -2,9 +2,9 @@ From: Christian Lamparter <chunkeey@googlemail.com>
 Subject: SoC: add qualcomm syscon
 --- a/drivers/soc/qcom/Kconfig
 +++ b/drivers/soc/qcom/Kconfig
 Subject: SoC: add qualcomm syscon
 --- a/drivers/soc/qcom/Kconfig
 +++ b/drivers/soc/qcom/Kconfig
-@@ -248,4 +248,11 @@ config QCOM_ICC_BWMON
-         the fixed bandwidth votes from cpufreq (CPU nodes) thus achieve high
-         memory throughput even with lower CPU frequencies.
+@@ -291,4 +291,11 @@ config QCOM_INLINE_CRYPTO_ENGINE
+       tristate
+       select QCOM_SCM
  
 +config QCOM_TCSR
 +      tristate "QCOM Top Control and Status Registers"
  
 +config QCOM_TCSR
 +      tristate "QCOM Top Control and Status Registers"
@@ -16,7 +16,7 @@ Subject: SoC: add qualcomm syscon
  endmenu
 --- a/drivers/soc/qcom/Makefile
 +++ b/drivers/soc/qcom/Makefile
  endmenu
 --- a/drivers/soc/qcom/Makefile
 +++ b/drivers/soc/qcom/Makefile
-@@ -29,3 +29,4 @@ obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
+@@ -32,3 +32,4 @@ obj-$(CONFIG_QCOM_KRYO_L2_ACCESSORS) +=
  obj-$(CONFIG_QCOM_ICC_BWMON)  += icc-bwmon.o
  qcom_ice-objs                 += ice.o
  obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)       += qcom_ice.o
  obj-$(CONFIG_QCOM_ICC_BWMON)  += icc-bwmon.o
  qcom_ice-objs                 += ice.o
  obj-$(CONFIG_QCOM_INLINE_CRYPTO_ENGINE)       += qcom_ice.o
index c73e40429c8ae1cd7d14b9ca0f3a98485e9f3dc9..8cb424c050b128207c27759517ddde7dbe1fc675 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
 
 --- a/drivers/firmware/qcom_scm.c
 +++ b/drivers/firmware/qcom_scm.c
 
 --- a/drivers/firmware/qcom_scm.c
 +++ b/drivers/firmware/qcom_scm.c
-@@ -1466,7 +1466,8 @@ static int qcom_scm_probe(struct platfor
+@@ -1522,7 +1522,8 @@ static int qcom_scm_probe(struct platfor
  static void qcom_scm_shutdown(struct platform_device *pdev)
  {
        /* Clean shutdown, disable download mode to allow normal restart */
  static void qcom_scm_shutdown(struct platform_device *pdev)
  {
        /* Clean shutdown, disable download mode to allow normal restart */