kernel: bump 5.10 to 5.10.50
authorRui Salvaterra <rsalvaterra@gmail.com>
Wed, 14 Jul 2021 16:42:28 +0000 (17:42 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Jul 2021 11:27:03 +0000 (13:27 +0200)
No deleted or manually refreshed patches.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
14 files changed:
include/kernel-version.mk
target/linux/ath79/patches-5.10/0003-leds-add-reset-controller-based-driver.patch
target/linux/ath79/patches-5.10/408-mtd-redboot_partition_scan.patch
target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
target/linux/ath79/patches-5.10/920-mikrotik-rb4xx.patch
target/linux/bcm63xx/patches-5.10/400-bcm963xx_flashmap.patch
target/linux/generic/hack-5.10/221-module_exports.patch
target/linux/generic/hack-5.10/661-use_fq_codel_by_default.patch
target/linux/generic/pending-5.10/205-backtrace_module_info.patch
target/linux/generic/pending-5.10/419-mtd-redboot-add-of_match_table-with-DT-binding.patch
target/linux/generic/pending-5.10/420-mtd-redboot_space.patch
target/linux/generic/pending-5.10/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/mediatek/patches-5.10/410-bt-mtk-serial-fix.patch
target/linux/mediatek/patches-5.10/800-ubnt-ledbar-driver.patch

index 0af8d05fd12e15855f9ffabaf72a758363e974fa..2948f7b5e8c885279566e143cd388677213726fe 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .132
 endif
 
 LINUX_VERSION-5.4 = .132
-LINUX_VERSION-5.10 = .49
+LINUX_VERSION-5.10 = .50
 
 LINUX_KERNEL_HASH-5.4.132 = 8466adbfb3579e751ede683496df7bb20f258b5f882250f3dd82be63736d00ef
 
 LINUX_KERNEL_HASH-5.4.132 = 8466adbfb3579e751ede683496df7bb20f258b5f882250f3dd82be63736d00ef
-LINUX_KERNEL_HASH-5.10.49 = b0d16de7e79c272b01996ad8ff8bdf3a6a011bc0c94049baccf69f05dde3025e
+LINUX_KERNEL_HASH-5.10.50 = 8bda327a7d95acfff8f87fb6ef4223e3194fa22195f5551249a9aa3393bfb436
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index a023d4c6447e3da6b88642a1c1f0692a71e50772..68b831036576c293f8becf920000dbc15663d732 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
 
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -928,6 +928,17 @@ config LEDS_ACER_A500
+@@ -929,6 +929,17 @@ config LEDS_ACER_A500
          This option enables support for the Power Button LED of
          Acer Iconia Tab A500.
  
          This option enables support for the Power Button LED of
          Acer Iconia Tab A500.
  
index 8f3ee32f5776a392c62ec08a89eec222e7251563..e5b06e14a56837d04c7906b877e7db8e38a68ec4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
-@@ -85,12 +85,18 @@ static int parse_redboot_partitions(stru
+@@ -90,12 +90,18 @@ static int parse_redboot_partitions(stru
  
        parse_redboot_of(master);
  
  
        parse_redboot_of(master);
  
@@ -19,7 +19,7 @@
                                return -EIO;
                        }
                        offset -= master->erasesize;
                                return -EIO;
                        }
                        offset -= master->erasesize;
-@@ -103,10 +109,6 @@ static int parse_redboot_partitions(stru
+@@ -108,10 +114,6 @@ static int parse_redboot_partitions(stru
                                goto nogood;
                }
        }
                                goto nogood;
                }
        }
@@ -30,7 +30,7 @@
  
        printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
               master->name, offset);
  
        printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
               master->name, offset);
-@@ -179,6 +181,11 @@ static int parse_redboot_partitions(stru
+@@ -184,6 +186,11 @@ static int parse_redboot_partitions(stru
        }
        if (i == numslots) {
                /* Didn't find it */
        }
        if (i == numslots) {
                /* Didn't find it */
index c1cb0dae668156e91608b56b65e76d8d749cc25a..b9290dee1c91656e31e81f370705ae07d89a9d45 100644 (file)
                case IPV6_2292HOPOPTS:
 --- a/net/ipv6/exthdrs.c
 +++ b/net/ipv6/exthdrs.c
                case IPV6_2292HOPOPTS:
 --- a/net/ipv6/exthdrs.c
 +++ b/net/ipv6/exthdrs.c
-@@ -949,7 +949,7 @@ static bool ipv6_hop_jumbo(struct sk_buf
+@@ -948,7 +948,7 @@ static bool ipv6_hop_jumbo(struct sk_buf
                goto drop;
        }
  
                goto drop;
        }
  
index 01d623ab87e370c4b09c8a65d37dc5208d5d45ae..7c3c91817f4520e12ec229e37260186189114154 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mfd/Kconfig
 +++ b/drivers/mfd/Kconfig
 --- a/drivers/mfd/Kconfig
 +++ b/drivers/mfd/Kconfig
-@@ -2141,6 +2141,14 @@ config RAVE_SP_CORE
+@@ -2142,6 +2142,14 @@ config RAVE_SP_CORE
          Select this to get support for the Supervisory Processor
          device found on several devices in RAVE line of hardware.
  
          Select this to get support for the Supervisory Processor
          device found on several devices in RAVE line of hardware.
  
index f57950b44a652c6d4cde68f8d2b6acc1b2652d50..5a9532c3214890c338fc7f7c885250c5b7b7b404 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
        .width                  = 2,
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
        .width                  = 2,
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
-@@ -79,6 +79,7 @@ static int parse_redboot_partitions(stru
+@@ -84,6 +84,7 @@ static int parse_redboot_partitions(stru
        int nulllen = 0;
        int numslots;
        unsigned long offset;
        int nulllen = 0;
        int numslots;
        unsigned long offset;
@@ -31,7 +31,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        static char nullstring[] = "unallocated";
  #endif
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        static char nullstring[] = "unallocated";
  #endif
-@@ -185,6 +186,16 @@ static int parse_redboot_partitions(stru
+@@ -190,6 +191,16 @@ static int parse_redboot_partitions(stru
                goto out;
        }
  
                goto out;
        }
  
@@ -48,7 +48,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
        for (i = 0; i < numslots; i++) {
                struct fis_list *new_fl, **prev;
  
        for (i = 0; i < numslots; i++) {
                struct fis_list *new_fl, **prev;
  
-@@ -205,10 +216,10 @@ static int parse_redboot_partitions(stru
+@@ -210,10 +221,10 @@ static int parse_redboot_partitions(stru
                        goto out;
                }
                new_fl->img = &buf[i];
                        goto out;
                }
                new_fl->img = &buf[i];
index e6854138e7963d994675309434777b913fd0c9eb..2fcb2d9809a13fdec7783c9c1eff07b029904748 100644 (file)
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
            "__kstrtabns_" #sym ":                                      \n"     \
 --- a/scripts/Makefile.build
 +++ b/scripts/Makefile.build
            "__kstrtabns_" #sym ":                                      \n"     \
 --- a/scripts/Makefile.build
 +++ b/scripts/Makefile.build
-@@ -366,7 +366,7 @@ targets += $(lib-y) $(always-y) $(MAKECM
+@@ -367,7 +367,7 @@ targets += $(lib-y) $(always-y) $(MAKECM
  # Linker scripts preprocessor (.lds.S -> .lds)
  # ---------------------------------------------------------------------------
  quiet_cmd_cpp_lds_S = LDS     $@
  # Linker scripts preprocessor (.lds.S -> .lds)
  # ---------------------------------------------------------------------------
  quiet_cmd_cpp_lds_S = LDS     $@
index 863738e2ef333d47000095911d11d539f37cc942..33c8c55ab66ffc4b533f1e4fd8fc7c02616cfdfc 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/net/sch_generic.h
 +++ b/include/net/sch_generic.h
 
 --- a/include/net/sch_generic.h
 +++ b/include/net/sch_generic.h
-@@ -611,12 +611,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
+@@ -623,12 +623,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
  extern struct Qdisc_ops pfifo_fast_ops;
  extern struct Qdisc_ops mq_qdisc_ops;
  extern struct Qdisc_ops noqueue_qdisc_ops;
  extern struct Qdisc_ops pfifo_fast_ops;
  extern struct Qdisc_ops mq_qdisc_ops;
  extern struct Qdisc_ops noqueue_qdisc_ops;
index 595321475749515b943e2811dcd951def0ab0190..f46877f254dd262bc1f5e42aec3477504cea2c9d 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/lib/vsprintf.c
 +++ b/lib/vsprintf.c
 
 --- a/lib/vsprintf.c
 +++ b/lib/vsprintf.c
-@@ -957,8 +957,10 @@ char *symbol_string(char *buf, char *end
+@@ -983,8 +983,10 @@ char *symbol_string(char *buf, char *end
                    struct printf_spec spec, const char *fmt)
  {
        unsigned long value;
                    struct printf_spec spec, const char *fmt)
  {
        unsigned long value;
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif
  
        if (fmt[1] == 'R')
  #endif
  
        if (fmt[1] == 'R')
-@@ -975,8 +977,14 @@ char *symbol_string(char *buf, char *end
+@@ -1001,8 +1003,14 @@ char *symbol_string(char *buf, char *end
  
        return string_nocheck(buf, end, sym, spec);
  #else
  
        return string_nocheck(buf, end, sym, spec);
  #else
index 8358a307cd8eab9b374ff2be49d02dd93c254ef1..7692f484ae0c7ba036302e3282040412eedb96a7 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
 
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
 
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
-@@ -300,6 +300,7 @@ static int parse_redboot_partitions(stru
+@@ -305,6 +305,7 @@ static int parse_redboot_partitions(stru
  
  static const struct of_device_id mtd_parser_redboot_of_match_table[] = {
        { .compatible = "redboot-fis" },
  
  static const struct of_device_id mtd_parser_redboot_of_match_table[] = {
        { .compatible = "redboot-fis" },
index a2cf8389898d7297e5f3f986e7d5379be91e6ae0..a3cd4ecf1f9bf799ad57f6d7892838df81bcaae4 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
 
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
-@@ -274,14 +274,21 @@ static int parse_redboot_partitions(stru
+@@ -279,14 +279,21 @@ static int parse_redboot_partitions(stru
  #endif
                names += strlen(names)+1;
  
  #endif
                names += strlen(names)+1;
  
index ddb94fbe558f3f3e332f17c5b79738d72fa956e8..89eb7d61b3b7ee0d40fb4c53a4accbcafbf4c0bd 100644 (file)
@@ -311,7 +311,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  /**
   * ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
   *   @t: the outgoing tunnel device
  /**
   * ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
   *   @t: the outgoing tunnel device
-@@ -1306,6 +1454,7 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1304,6 +1452,7 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
                u8 protocol)
  {
        struct ip6_tnl *t = netdev_priv(dev);
                u8 protocol)
  {
        struct ip6_tnl *t = netdev_priv(dev);
@@ -319,7 +319,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        struct ipv6hdr *ipv6h;
        const struct iphdr  *iph;
        int encap_limit = -1;
        struct ipv6hdr *ipv6h;
        const struct iphdr  *iph;
        int encap_limit = -1;
-@@ -1405,6 +1554,18 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1403,6 +1552,18 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
        fl6.flowi6_uid = sock_net_uid(dev_net(dev), NULL);
        dsfield = INET_ECN_encapsulate(dsfield, orig_dsfield);
  
        fl6.flowi6_uid = sock_net_uid(dev_net(dev), NULL);
        dsfield = INET_ECN_encapsulate(dsfield, orig_dsfield);
  
index 8dc680d180736ce996de9d9857c65e88880729a1..381eaab5e2b844f27cf738b7d663aa4e670fdbbe 100644 (file)
@@ -19,7 +19,7 @@
        },
        [PORT_NPCM] = {
                .name           = "Nuvoton 16550",
        },
        [PORT_NPCM] = {
                .name           = "Nuvoton 16550",
-@@ -2699,6 +2699,11 @@ serial8250_do_set_termios(struct uart_po
+@@ -2712,6 +2712,11 @@ serial8250_do_set_termios(struct uart_po
        unsigned long flags;
        unsigned int baud, quot, frac = 0;
  
        unsigned long flags;
        unsigned int baud, quot, frac = 0;
  
index 013391e1d9fcb7717047613e016077165b5fbafd..92264eedf9cc4b32ce2ffb480f2fa628761d2245 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -928,6 +928,16 @@ config LEDS_ACER_A500
+@@ -929,6 +929,16 @@ config LEDS_ACER_A500
          This option enables support for the Power Button LED of
          Acer Iconia Tab A500.
  
          This option enables support for the Power Button LED of
          Acer Iconia Tab A500.