treewide: fix spelling 'seperate' -> 'separate'
authorDaniel Golle <daniel@makrotopia.org>
Sun, 28 Feb 2021 23:58:10 +0000 (23:58 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 28 Feb 2021 23:59:21 +0000 (23:59 +0000)
This popular spelling mistake was also introduced by myself lately.
Fix it everywhere.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
12 files changed:
config/Config-images.in
include/image-commands.mk
include/kernel-defaults.mk
package/base-files/image-config.in
package/firmware/b43legacy-firmware/Makefile
package/kernel/mac80211/broadcom.mk
scripts/target-metadata.pl
target/Config.in
target/linux/layerscape/patches-5.4/802-can-0006-can-rx-offload-Prepare-for-CAN-FD-support.patch
target/linux/mediatek/Makefile
target/linux/rockchip/patches-5.10/100-rockchip-use-system-LED-for-OpenWrt.patch
target/linux/rockchip/patches-5.4/100-rockchip-use-system-LED-for-OpenWrt.patch

index b1f5b4371980d1455dff178ffae8fabc07e875b7..26917267cf95c9b1a5c8b099dc943f9829fa23f4 100644 (file)
@@ -17,7 +17,7 @@ menu "Target Images"
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_lantiq
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_mpc85xx
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_lantiq
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_mpc85xx
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
-                       default TARGET_INITRAMFS_COMPRESSION_XZ if USES_SEPERATE_INITRAMFS
+                       default TARGET_INITRAMFS_COMPRESSION_XZ if USES_SEPARATE_INITRAMFS
                        default TARGET_INITRAMFS_COMPRESSION_NONE
                        depends on TARGET_ROOTFS_INITRAMFS
                        help
                        default TARGET_INITRAMFS_COMPRESSION_NONE
                        depends on TARGET_ROOTFS_INITRAMFS
                        help
@@ -36,11 +36,11 @@ menu "Target Images"
                                bool "lzma"
 
                        config TARGET_INITRAMFS_COMPRESSION_LZO
                                bool "lzma"
 
                        config TARGET_INITRAMFS_COMPRESSION_LZO
-                               depends on !TARGET_ROOTFS_INITRAMFS_SEPERATE
+                               depends on !TARGET_ROOTFS_INITRAMFS_SEPARATE
                                bool "lzo"
 
                        config TARGET_INITRAMFS_COMPRESSION_LZ4
                                bool "lzo"
 
                        config TARGET_INITRAMFS_COMPRESSION_LZ4
-                               depends on !TARGET_ROOTFS_INITRAMFS_SEPERATE
+                               depends on !TARGET_ROOTFS_INITRAMFS_SEPARATE
                                bool "lz4"
 
                        config TARGET_INITRAMFS_COMPRESSION_XZ
                                bool "lz4"
 
                        config TARGET_INITRAMFS_COMPRESSION_XZ
@@ -65,12 +65,12 @@ menu "Target Images"
                        help
                          Ignore the initramfs passed by the bootloader.
 
                        help
                          Ignore the initramfs passed by the bootloader.
 
-               config TARGET_ROOTFS_INITRAMFS_SEPERATE
-                       bool "seperate ramdisk"
-                       depends on USES_SEPERATE_INITRAMFS && TARGET_ROOTFS_INITRAMFS && !TARGET_INITRAMFS_FORCE
-                       default y if USES_SEPERATE_INITRAMFS
+               config TARGET_ROOTFS_INITRAMFS_SEPARATE
+                       bool "separate ramdisk"
+                       depends on USES_SEPARATE_INITRAMFS && TARGET_ROOTFS_INITRAMFS && !TARGET_INITRAMFS_FORCE
+                       default y if USES_SEPARATE_INITRAMFS
                        help
                        help
-                         Generate seperate initrd.cpio instead of embedding it.
+                         Generate separate initrd.cpio instead of embedding it.
                          This is useful for generating images with a dedicated
                          ramdisk e.g. in U-Boot's uImage and uImage.FIT formats.
 
                          This is useful for generating images with a dedicated
                          ramdisk e.g. in U-Boot's uImage and uImage.FIT formats.
 
index a1edc3265e3bd979c0ed62fd35faf3bccfd84396..10b23e027b1de8b123ee5a3683e9f2e524a2ad5e 100644 (file)
@@ -210,7 +210,7 @@ define Build/fit
                $(if $(word 2,$(1)),-d $(word 2,$(1))) -C $(word 1,$(1)) \
                $(if $(findstring with-rootfs,$(word 3,$(1))),-r $(IMAGE_ROOTFS)) \
                $(if $(findstring with-initrd,$(word 3,$(1))), \
                $(if $(word 2,$(1)),-d $(word 2,$(1))) -C $(word 1,$(1)) \
                $(if $(findstring with-rootfs,$(word 3,$(1))),-r $(IMAGE_ROOTFS)) \
                $(if $(findstring with-initrd,$(word 3,$(1))), \
-                       $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPERATE), \
+                       $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPARATE), \
                                -i $(KERNEL_BUILD_DIR)/initrd.cpio$(strip $(call Build/initrd_compression)))) \
                -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                $(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
                                -i $(KERNEL_BUILD_DIR)/initrd.cpio$(strip $(call Build/initrd_compression)))) \
                -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                $(if $(DEVICE_FDT_NUM),-n $(DEVICE_FDT_NUM)) \
index c246857cd3a41a5718da75a9d2afb8b782c014fd..ade31b0dc19cc1d30f1ff21107590e76da85b2b2 100644 (file)
@@ -48,7 +48,7 @@ else
 endif
 
 ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
 endif
 
 ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-  ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPERATE),y)
+  ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPARATE),y)
     define Kernel/SetInitramfs/PreConfigure
        grep -v -e CONFIG_BLK_DEV_INITRD $(LINUX_DIR)/.config.old > $(LINUX_DIR)/.config
        echo 'CONFIG_BLK_DEV_INITRD=y' >> $(LINUX_DIR)/.config
     define Kernel/SetInitramfs/PreConfigure
        grep -v -e CONFIG_BLK_DEV_INITRD $(LINUX_DIR)/.config.old > $(LINUX_DIR)/.config
        echo 'CONFIG_BLK_DEV_INITRD=y' >> $(LINUX_DIR)/.config
@@ -73,7 +73,7 @@ endif
        rm -f $(LINUX_DIR)/.config.prev
        mv $(LINUX_DIR)/.config $(LINUX_DIR)/.config.old
        $(call Kernel/SetInitramfs/PreConfigure)
        rm -f $(LINUX_DIR)/.config.prev
        mv $(LINUX_DIR)/.config $(LINUX_DIR)/.config.old
        $(call Kernel/SetInitramfs/PreConfigure)
-  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPERATE),y)
+  ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPARATE),y)
        echo 'CONFIG_INITRAMFS_ROOT_UID=$(shell id -u)' >> $(LINUX_DIR)/.config
        echo 'CONFIG_INITRAMFS_ROOT_GID=$(shell id -g)' >> $(LINUX_DIR)/.config
        echo "$(if $(CONFIG_TARGET_INITRAMFS_FORCE),CONFIG_INITRAMFS_FORCE=y,# CONFIG_INITRAMFS_FORCE is not set)" >> $(LINUX_DIR)/.config
        echo 'CONFIG_INITRAMFS_ROOT_UID=$(shell id -u)' >> $(LINUX_DIR)/.config
        echo 'CONFIG_INITRAMFS_ROOT_GID=$(shell id -g)' >> $(LINUX_DIR)/.config
        echo "$(if $(CONFIG_TARGET_INITRAMFS_FORCE),CONFIG_INITRAMFS_FORCE=y,# CONFIG_INITRAMFS_FORCE is not set)" >> $(LINUX_DIR)/.config
@@ -159,7 +159,7 @@ define Kernel/CompileImage/Initramfs
        $(CP) $(GENERIC_PLATFORM_DIR)/other-files/init $(TARGET_DIR)/init
        $(if $(SOURCE_DATE_EPOCH),touch -hcd "@$(SOURCE_DATE_EPOCH)" $(TARGET_DIR)/init)
        rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
        $(CP) $(GENERIC_PLATFORM_DIR)/other-files/init $(TARGET_DIR)/init
        $(if $(SOURCE_DATE_EPOCH),touch -hcd "@$(SOURCE_DATE_EPOCH)" $(TARGET_DIR)/init)
        rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
-ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPERATE),y)
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS_SEPARATE),y)
 ifeq ($(CONFIG_EXTERNAL_CPIO),y)
        $(CP) $(CONFIG_EXTERNAL_CPIO) $(KERNEL_BUILD_DIR)/initrd.cpio
 else
 ifeq ($(CONFIG_EXTERNAL_CPIO),y)
        $(CP) $(CONFIG_EXTERNAL_CPIO) $(KERNEL_BUILD_DIR)/initrd.cpio
 else
index b5cd90f6152df003b6f2c95c5479a84a7138f59e..ac406bc456bd91c17e5ffef7da01314a5477bdc5 100644 (file)
@@ -119,7 +119,7 @@ menuconfig INITOPT
                prompt "Environment variables to set when starting init (start with none)" if INITOPT
                default ""
                help
                prompt "Environment variables to set when starting init (start with none)" if INITOPT
                default ""
                help
-                       Should be a space seperated list of variable assignments.  These
+                       Should be a space separated list of variable assignments.  These
                        variables will be present in the environment.  Spaces may not be
                        present (including through expansion) even in a quoted string
                        (env doesn't understanding quoting).
                        variables will be present in the environment.  Spaces may not be
                        present (including through expansion) even in a quoted string
                        (env doesn't understanding quoting).
index ecbfc3229309d8f38b8d492a9eabf446d1b8e10e..9ca65a8a325feb32733bddb396ffef03478e05f6 100644 (file)
@@ -42,7 +42,7 @@ define Package/b43legacy-firmware/config
                depends on B43LEGACY_FW_SQUASH
                default "1,2,3,4"
                help
                depends on B43LEGACY_FW_SQUASH
                default "1,2,3,4"
                help
-                 This is a comma seperated list of core revision numbers.
+                 This is a comma separated list of core revision numbers.
 
                  Example (keep files for rev4 only):
                    4
 
                  Example (keep files for rev4 only):
                    4
index fb576c5809aaef3ceea53931d04e15c973f4287f..473bbf597c389c0c8f81e01a77fead75a2bc61c1 100644 (file)
@@ -209,7 +209,7 @@ config PACKAGE_B43_USE_BCMA
                default "16,28,29,30" if TARGET_bcm47xx_mips74k
                default "5,6,7,8,9,10,11,13,15,16,28,29,30"
                help
                default "16,28,29,30" if TARGET_bcm47xx_mips74k
                default "5,6,7,8,9,10,11,13,15,16,28,29,30"
                help
-                 This is a comma seperated list of core revision numbers.
+                 This is a comma separated list of core revision numbers.
 
                  Example (keep files for rev5 only):
                    5
 
                  Example (keep files for rev5 only):
                    5
@@ -224,7 +224,7 @@ config PACKAGE_B43_USE_BCMA
                default "N,HT" if TARGET_bcm47xx_mips74k
                default "G,N,LP,HT"
                help
                default "N,HT" if TARGET_bcm47xx_mips74k
                default "G,N,LP,HT"
                help
-                 This is a comma seperated list of PHY types:
+                 This is a comma separated list of PHY types:
                    A  => A-PHY
                    AG => Dual A-PHY G-PHY
                    G  => G-PHY
                    A  => A-PHY
                    AG => Dual A-PHY G-PHY
                    G  => G-PHY
index 4128d544612014834f9fec065bba802148b47537..09a2d993c1b0a369b37be5af1a60167e35fcc651 100755 (executable)
@@ -33,7 +33,7 @@ sub target_config_features(@) {
                /^fpu$/ and $ret .= "\tselect HAS_FPU\n";
                /^spe_fpu$/ and $ret .= "\tselect HAS_SPE_FPU\n";
                /^ramdisk$/ and $ret .= "\tselect USES_INITRAMFS\n";
                /^fpu$/ and $ret .= "\tselect HAS_FPU\n";
                /^spe_fpu$/ and $ret .= "\tselect HAS_SPE_FPU\n";
                /^ramdisk$/ and $ret .= "\tselect USES_INITRAMFS\n";
-               /^seperate_ramdisk$/ and $ret .= "\tselect USES_INITRAMFS\n\tselect USES_SEPERATE_INITRAMFS\n";
+               /^separate_ramdisk$/ and $ret .= "\tselect USES_INITRAMFS\n\tselect USES_SEPARATE_INITRAMFS\n";
                /^powerpc64$/ and $ret .= "\tselect powerpc64\n";
                /^nommu$/ and $ret .= "\tselect NOMMU\n";
                /^mips16$/ and $ret .= "\tselect HAS_MIPS16\n";
                /^powerpc64$/ and $ret .= "\tselect powerpc64\n";
                /^nommu$/ and $ret .= "\tselect NOMMU\n";
                /^mips16$/ and $ret .= "\tselect HAS_MIPS16\n";
index 9dbc5ffe465096b2748af55f74081093eee96926..86d39ce07c61fd3cf733d614d2f7abf9694fee96 100644 (file)
@@ -51,7 +51,7 @@ config USES_DEVICETREE
 config USES_INITRAMFS
        bool
 
 config USES_INITRAMFS
        bool
 
-config USES_SEPERATE_INITRAMFS
+config USES_SEPARATE_INITRAMFS
        bool
 
 config USES_SQUASHFS
        bool
 
 config USES_SQUASHFS
index c88f14f01fcc61ca92b36be583732afe69e2ef70..51eb42494e09225d4f0e3ef820fdb7e04725bffc 100644 (file)
@@ -3,7 +3,7 @@ From: Joakim Zhang <qiangqing.zhang@nxp.com>
 Date: Fri, 12 Jul 2019 08:02:38 +0000
 Subject: [PATCH] can: rx-offload: Prepare for CAN FD support
 
 Date: Fri, 12 Jul 2019 08:02:38 +0000
 Subject: [PATCH] can: rx-offload: Prepare for CAN FD support
 
-The skbs for classic CAN and CAN FD frames are allocated with seperate
+The skbs for classic CAN and CAN FD frames are allocated with separate
 functions: alloc_can_skb() and alloc_canfd_skb().
 
 In order to support CAN FD frames via the rx-offload helper, the driver
 functions: alloc_can_skb() and alloc_canfd_skb().
 
 In order to support CAN FD frames via the rx-offload helper, the driver
index e2e44c78bbaa688b8f80cd5d50492dc2f7385880..2ee00e5d1763dd423e5ce84c3432e1038036d089 100644 (file)
@@ -6,7 +6,7 @@ ARCH:=arm
 BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
 SUBTARGETS:=mt7622 mt7623 mt7629
 BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
 SUBTARGETS:=mt7622 mt7623 mt7629
-FEATURES:=squashfs nand seperate_ramdisk fpu
+FEATURES:=squashfs nand separate_ramdisk fpu
 
 KERNEL_PATCHVER:=5.4
 KERNEL_TESTING_PATCHVER:=5.10
 
 KERNEL_PATCHVER:=5.4
 KERNEL_TESTING_PATCHVER:=5.10
index 7f9af85b1d3767e3550e5806cce2c62a9b535d7c..7b3b50ffd85e4d24d391ae4d0203f69d7601d9aa 100644 (file)
@@ -5,7 +5,7 @@ Subject: [PATCH] rockchip: use system LED for OpenWrt
 
 Use the SYS LED on the casing for showing system status.
 
 
 Use the SYS LED on the casing for showing system status.
 
-This patch is kept seperate from the NanoPi R2S support patch, as i plan
+This patch is kept separate from the NanoPi R2S support patch, as i plan
 on submitting the device support upstream.
 
 Signed-off-by: David Bauer <mail@david-bauer.net>
 on submitting the device support upstream.
 
 Signed-off-by: David Bauer <mail@david-bauer.net>
index 7f9af85b1d3767e3550e5806cce2c62a9b535d7c..7b3b50ffd85e4d24d391ae4d0203f69d7601d9aa 100644 (file)
@@ -5,7 +5,7 @@ Subject: [PATCH] rockchip: use system LED for OpenWrt
 
 Use the SYS LED on the casing for showing system status.
 
 
 Use the SYS LED on the casing for showing system status.
 
-This patch is kept seperate from the NanoPi R2S support patch, as i plan
+This patch is kept separate from the NanoPi R2S support patch, as i plan
 on submitting the device support upstream.
 
 Signed-off-by: David Bauer <mail@david-bauer.net>
 on submitting the device support upstream.
 
 Signed-off-by: David Bauer <mail@david-bauer.net>