AA: backport 6in4 from trunk
authorSteven Barth <cyrus@openwrt.org>
Fri, 24 May 2013 13:03:32 +0000 (13:03 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 24 May 2013 13:03:32 +0000 (13:03 +0000)
SVN-Revision: 36706

package/6in4/Makefile
package/6in4/files/6in4.sh

index fdab290861ec399792fabe10adc45b652698e83d..7090234358d221371b7582a250040bbecec78d73 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=11
+PKG_VERSION:=14
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 71bc68940c6bf0956acced3779dcaaab237294e5..647a2f89cfdc573cdac77858812e05463429cf43 100755 (executable)
@@ -14,10 +14,10 @@ proto_6in4_setup() {
        local iface="$2"
        local link="6in4-$cfg"
 
-       local mtu ttl ipaddr peeraddr ip6addr tunnelid username password
-       json_get_vars mtu ttl ipaddr peeraddr ip6addr tunnelid username password
+       local mtu ttl ipaddr peeraddr ip6addr ip6prefix tunnelid username password
+       json_get_vars mtu ttl ipaddr peeraddr ip6addr ip6prefix tunnelid username password
 
-       [ -z "$ip6addr" -o -z "$peeraddr" ] && {
+       [ -z "$peeraddr" ] && {
                proto_notify_error "$cfg" "MISSING_ADDRESS"
                proto_block_restart "$cfg"
                return
@@ -33,14 +33,18 @@ proto_6in4_setup() {
                fi
        }
 
-       local local6="${ip6addr%%/*}"
-       local mask6="${ip6addr##*/}"
-       [[ "$local6" = "$mask6" ]] && mask6=
-
        proto_init_update "$link" 1
-       proto_add_ipv6_address "$local6" "$mask6"
        proto_add_ipv6_route "::" 0
 
+       [ -n "$ip6addr" ] && {
+               local local6="${ip6addr%%/*}"
+               local mask6="${ip6addr##*/}"
+               [[ "$local6" = "$mask6" ]] && mask6=
+               proto_add_ipv6_address "$local6" "$mask6"
+       }
+
+       [ -n "$ip6prefix" ] && proto_add_ipv6_prefix "$ip6prefix"
+
        proto_add_tunnel
        json_add_string mode sit
        json_add_int mtu "${mtu:-1280}"
@@ -61,8 +65,10 @@ proto_6in4_setup() {
                local max=3
 
                while [ $((++try)) -le $max ]; do
-                       wget -qO/dev/null "$url" 2>/dev/null && break
-                       sleep 1
+                       ( exec wget -qO/dev/null "$url" 2>/dev/null ) &
+                       local pid=$!
+                       ( sleep 5; kill $pid 2>/dev/null ) &
+                       wait $pid && break
                done
        }
 }
@@ -77,6 +83,7 @@ proto_6in4_init_config() {
 
        proto_config_add_string "ipaddr"
        proto_config_add_string "ip6addr"
+       proto_config_add_string "ip6prefix"
        proto_config_add_string "peeraddr"
        proto_config_add_string "tunnelid"
        proto_config_add_string "username"