openvswitch: add openvswitch-python subpackage
authorAlexandru Ardelean <aa@ocedo.com>
Thu, 18 Sep 2014 14:03:25 +0000 (17:03 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Fri, 17 Oct 2014 15:02:59 +0000 (18:02 +0300)
Requires python package.
Required by other openvswitch subpackages (like openvswitch-python).

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
net/openvswitch/Makefile

index 710e89845a573599604fd852063f9784240cd704..bf4873704fd6e73d53e6353704d51f723f62f525 100644 (file)
@@ -26,6 +26,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
+$(call include_mk, python-package.mk)
 
 PKG_FIXUP=libtool
 
@@ -56,6 +57,16 @@ define Package/openvswitch/description
   Provides the main userspace components required for Open vSwitch to function.
 endef
 
+define Package/openvswitch-python
+  $(call Package/openvswitch/Default)
+  TITLE:=Open vSwitch Python Support
+  DEPENDS:=@PACKAGE_openvswitch +PACKAGE_openvswitch:openvswitch +python
+endef
+
+define Package/openvswitch-python/description
+  Provides bindings and libraries for using Python to manipulate/work with Open vSwitch.
+endef
+
 define Package/openvswitch-benchmark
   $(call Package/openvswitch/Default)
   TITLE:=Open vSwitch Userspace Package
@@ -141,6 +152,11 @@ define Package/openvswitch/install
        $(INSTALL_CONF) $(PKG_BUILD_DIR)/vswitchd/vswitch.ovsschema $(1)/usr/share/openvswitch/
 endef
 
+define Package/openvswitch-python/install
+       $(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/
+       $(CP) $(PKG_BUILD_DIR)/python/ovs/ $(1)/usr/lib/python$(PYTHON_VERSION)/
+endef
+
 define Package/openvswitch-benchmark/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-benchmark $(1)/usr/bin/
@@ -152,6 +168,7 @@ define Package/openvswitch/postinst
 endef
 
 $(eval $(call BuildPackage,openvswitch))
+$(eval $(call BuildPackage,openvswitch-python))
 $(eval $(call BuildPackage,openvswitch-benchmark))
 $(eval $(call KernelPackage,openvswitch))