Merge pull request #10538 from TDT-AG/pr/20191113-mwan3
authorFlorian Eckert <fe@dev.tdt.de>
Mon, 18 Nov 2019 08:28:48 +0000 (09:28 +0100)
committerGitHub <noreply@github.com>
Mon, 18 Nov 2019 08:28:48 +0000 (09:28 +0100)
mwan3: add https ping possibility and a minor fix

net/mwan3/Makefile
net/mwan3/files/lib/mwan3/mwan3.sh
net/mwan3/files/usr/sbin/mwan3track

index cf37fc5b17e29ef5641e7448de640863cea5a70c..9815663fc57cfcab8e3a491de9c2d6d81beeba78 100644 (file)
@@ -8,10 +8,10 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mwan3
-PKG_VERSION:=2.8.1
-PKG_RELEASE:=1
+PKG_VERSION:=2.8.2
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Florian Eckert <fe@dev.tdt.de>
-PKG_LICENSE:=GPLv2
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
index ae7b398aa9377454359dc5182d37296d637ed4f8..88159e8b95c829f660db38cd66151a479846774e 100644 (file)
@@ -1004,7 +1004,7 @@ mwan3_set_user_iptables_rule()
                        case $proto in
                                tcp|udp)
                                [ "$global_logging" = "1" ] && [ "$rule_logging" = "1" ] && {
-                                       $IPT -A mwan3_rules \
+                                       $IPT4 -A mwan3_rules \
                                                -p $proto \
                                                -s $src_ip \
                                                -d $dest_ip $ipset \
index 5a36922301399b3725cb465651f38f65db791220..a88708f063a71a86ada11e24fdeabf32965a7a19 100755 (executable)
@@ -61,7 +61,7 @@ main() {
        local recovery_interval down up size
        local keep_failure_interval check_quality failure_latency
        local recovery_latency failure_loss recovery_loss
-       local max_ttl
+       local max_ttl httping_ssl
 
        [ -z "$5" ] && echo "Error: should not be started manually" && exit 0
 
@@ -75,6 +75,7 @@ main() {
 
        config_load mwan3
        config_get track_method $1 track_method ping
+       config_get_bool httping_ssl $1 httping_ssl 0
        validate_track_method $track_method $SRC_IP || {
                track_method=ping
                if validate_track_method $track_method; then
@@ -149,7 +150,11 @@ main() {
                                                result=$?
                                        ;;
                                        httping)
-                                               httping -y $SRC_IP -c $count -t $timeout -q $track_ip &> /dev/null
+                                               if [ "$httping_ssl" -eq 1 ]; then
+                                                       httping -y $SRC_IP -c $count -t $timeout -q "https://$track_ip" &> /dev/null
+                                               else
+                                                       httping -y $SRC_IP -c $count -t $timeout -q "http://$track_ip" &> /dev/null
+                                               fi
                                                result=$?
                                        ;;
                                        nping-tcp)