Merge pull request #659 from neheb/gsmm
authormicmac1 <sebastian_ml@gmx.net>
Thu, 22 Jul 2021 09:58:49 +0000 (11:58 +0200)
committerGitHub <noreply@github.com>
Thu, 22 Jul 2021 09:58:49 +0000 (11:58 +0200)
gsmlib: set C++ standard to 11

libs/gsmlib/Makefile

index 53ae116c9e07c2da64fb2c293399f5fadb54c039..7dae960939417f792f096834ac27c6e66d0d9c51 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gsmlib
 PKG_VERSION:=1.10-20140304
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/vbouchaud/gsmlib.git
@@ -62,6 +62,8 @@ define Package/gsm-utils/description
 Some simple command line programs to access GSM mobile phones via GSM modems.
 endef
 
+TARGET_CXXFLAGS += -std=c++11
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/$(PKG_NAME)
        $(INSTALL_DATA) \