monit: add libtool fixup 14260/head
authorRosen Penev <rosenp@gmail.com>
Thu, 17 Dec 2020 23:27:34 +0000 (15:27 -0800)
committerRosen Penev <rosenp@gmail.com>
Fri, 18 Dec 2020 05:58:10 +0000 (21:58 -0800)
It seems to fail locally without it:

Version mismatch error.  This is libtool 2.4.6 Debian-2.4.6-2, but the
definition of this LT_INIT comes from libtool 2.4.
You should recreate aclocal.m4 with macros from libtool 2.4.6 Debian-2.4.6-2
and run autoconf again.

Move MAINTAINER up for consistency between packages.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
admin/monit/Makefile

index 1c7d7195a39c94fa5da3bbaa5be8c0ce41eff6c2..f6ab3a43028970ce0f4f6971ec6d5eb6cbba7cee 100644 (file)
@@ -9,18 +9,20 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=monit
 PKG_VERSION:=5.26.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://mmonit.com/monit/dist
 PKG_HASH:=87fc4568a3af9a2be89040efb169e3a2e47b262f99e78d5ddde99dd89f02f3c2
 
+PKG_MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
 PKG_LICENSE:=AGPL-3.0
 PKG_LICENSE_FILES:=COPYING
 PKG_CPE_ID:=cpe:/a:tildeslash:monit
 
-PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=libtool
 PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,7 +32,6 @@ define Package/monit/Default
   DEPENDS:= +libpthread +zlib
   TITLE:=System services monitoring utility
   URL:=https://mmonit.com/monit/
-  MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
 endef
 
 define Package/monit/Default/description