coova-chilli: fix "struct sysinfo" redeclaration with recent uClibc.
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Sep 2013 12:53:25 +0000 (12:53 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 19 Sep 2013 12:53:25 +0000 (12:53 +0000)
Patch from http://lists.coova.org/pipermail/chilli/2013-August/002347.html -
refreshed and compile tested locally.

SVN-Revision: 38058

net/coova-chilli/Makefile
net/coova-chilli/patches/100-fix-sysinfo-redeclaration.patch [new file with mode: 0644]

index 3b350cb4dad476f5105900885eb9a04144882ec4..f4790a0266aa5e415ea9ecd3ba8521cfb40584d3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coova-chilli
 PKG_VERSION:=1.2.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ap.coova.org/chilli
diff --git a/net/coova-chilli/patches/100-fix-sysinfo-redeclaration.patch b/net/coova-chilli/patches/100-fix-sysinfo-redeclaration.patch
new file mode 100644 (file)
index 0000000..446eb63
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/src/system.h
++++ b/src/system.h
+@@ -76,10 +76,6 @@
+ #include <sys/stat.h>
+ #endif
+-#ifdef HAVE_SYS_SYSINFO_H
+-#include <sys/sysinfo.h>
+-#endif
+-
+ #ifdef HAVE_TIME_H
+ #include <time.h>
+ #endif
+@@ -132,6 +128,10 @@
+ #include <linux/un.h>
+ #endif
++#ifdef HAVE_SYS_SYSINFO_H
++#include <sys/sysinfo.h>
++#endif
++
+ #elif defined (__FreeBSD__)  || defined (__APPLE__) || defined (__OpenBSD__) || defined (__NetBSD__) 
+ #include <net/if.h>
+ #include <net/bpf.h>