strongswan: Fix indent for hw_offload, interface, priority
authorPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 26 Mar 2023 19:27:02 +0000 (13:27 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 26 Mar 2023 19:53:05 +0000 (13:53 -0600)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/strongswan/Makefile
net/strongswan/files/swanctl.init

index 8c38c703ddfee05032301f211eae978a53e62112..3bac8210c67b220b8ff44d1049b02702de7b08c9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
index 9d34b1041db03104d772e9036a4a7c2c6e9088be..b7af78446a6142a85445493f6ad0b26485539edd 100644 (file)
@@ -331,10 +331,10 @@ config_child() {
        [ -n "$local_subnet" ] && swanctl_xappend4 "local_ts = $local_subnet"
        [ -n "$remote_subnet" ] && swanctl_xappend4 "remote_ts = $remote_subnet"
 
-       [ -n "$hw_offload" ] && swanctl_append4 "hw_offload = $hw_offload"
+       [ -n "$hw_offload" ] && swanctl_xappend4 "hw_offload = $hw_offload"
        [ $ipcomp -eq 1 ] && swanctl_xappend4 "ipcomp = 1"
-       [ -n "$interface" ] && swanctl_append4 "interface = $interface"
-       [ -n "$priority" ] && swanctl_append4 "priority = $priority"
+       [ -n "$interface" ] && swanctl_xappend4 "interface = $interface"
+       [ -n "$priority" ] && swanctl_xappend4 "priority = $priority"
        [ -n "$if_id" ] && { swanctl_xappend4 "if_id_in = $if_id" ; swanctl_xappend4 "if_id_out = $if_id" ; }
        [ -n "$startaction" -a "$startaction" != "none" ] && swanctl_xappend4 "start_action = $startaction"
        [ -n "$closeaction" -a "$closeaction" != "none" ] && swanctl_xappend4 "close_action = $closeaction"