net/bwping: BWPing is a small utility for bandwidth measuring. (thank you Florian...
authorAlexandros C. Couloumbis <alex@ozo.com>
Tue, 19 Apr 2011 17:26:01 +0000 (17:26 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Tue, 19 Apr 2011 17:26:01 +0000 (17:26 +0000)
SVN-Revision: 26727

net/bwping/Makefile [new file with mode: 0644]
net/bwping/patches/100-getopt-returns-int.patch [new file with mode: 0644]

diff --git a/net/bwping/Makefile b/net/bwping/Makefile
new file mode 100644 (file)
index 0000000..9af6608
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bwping
+PKG_VERSION:=1.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/bwping
+PKG_MD5SUM:=4c2215551df7f00de8559fd0cd1ff4db
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bwping
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Open Source bandwidth measurement tool
+  URL:=http://bwping.sourceforge.net
+endef
+
+define Package/bwping/description
+  BWPing
+  BWPing is a bandwidth measurement tool based on ICMP echo
+  request/reply.  It is especially well suited for lossy links. BWPing
+  does not not require any special software on the remote host (only
+  the ability to respond on ICMP echo request messages).
+endef
+
+define Package/bwping/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,bwping))
diff --git a/net/bwping/patches/100-getopt-returns-int.patch b/net/bwping/patches/100-getopt-returns-int.patch
new file mode 100644 (file)
index 0000000..d0f3eb9
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN bwping-1.2.orig/bwping.c bwping-1.2/bwping.c
+--- bwping-1.2.orig/bwping.c   2010-01-22 17:49:29.000000000 +0000
++++ bwping-1.2/bwping.c        2010-12-07 12:30:26.000000000 +0000
+@@ -221,7 +221,7 @@
+     unsigned int              bufsize, tos, transmitted_number, received_number;
+     unsigned long int         kbps, pktsize, volume, rperiod, received_volume;
+     unsigned long long int    min_interval, interval, current_interval, integral_error;
+-    char                      ch;
++    int                               ch;
+     char                      *ep, *target;
+     fd_set                    fds;
+     struct sockaddr_in                to;