packages/parprouted: use new service functions
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:43:35 +0000 (23:43 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:43:35 +0000 (23:43 +0000)
SVN-Revision: 28915

net/parprouted/Makefile
net/parprouted/files/parprouted.init

index 4b00c796645c06e0623619a046790f10900f861e..7765c0130b8ad2d216ec91f3f60f8222445442d9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=parprouted
 PKG_VERSION:=0.64
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hazard.maks.net/parprouted/
index fe794405e41a1493f0dbd90567f40bf9dd34b31e..e2f6dc12bef39b6f4cb6aff215ef430b6d3fb613 100644 (file)
@@ -1,15 +1,17 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-BIN=parprouted
-DEFAULT=/etc/default/$BIN
+PROG="parprouted"
+COMMAND="/usr/sbin/$PROG"
+DEFAULT="/etc/default/$PROG"
 
 start() {
        [ -f $DEFAULT ] && . $DEFAULT
-       $BIN $OPTIONS
+       service_start $COMMAND $OPTIONS
 }
 
 stop() {
-       killall $BIN
+       service_stop $COMMAND
 }