bfdd: Fix compilation with uClibc-ng 10764/head
authorRosen Penev <rosenp@gmail.com>
Thu, 12 Dec 2019 03:54:51 +0000 (19:54 -0800)
committerRosen Penev <rosenp@gmail.com>
Thu, 12 Dec 2019 03:54:51 +0000 (19:54 -0800)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/bfdd/Makefile
net/bfdd/patches/010-uclibc.patch [new file with mode: 0644]

index 6f2df65e4a268ed47d20bb31d3b24fd61f58f7f7..6cd5beb8ada2db91a9e92f66109381ab9d5d4004 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bfdd
 PKG_SOURCE_DATE:=2019-08-22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_VERSION:=c54534beb524afc3972039f57b56ec65332b43f7
 PKG_SOURCE_URL:=https://codeload.github.com/rzalamena/bfdd/tar.gz/$(PKG_SOURCE_VERSION)?
@@ -46,6 +46,8 @@ define Package/bfdd/conffiles
 /etc/bfdd/bfdd.json
 endef
 
+TARGET_CFLAGS += -D_GNU_SOURCE
+
 define Package/bfdd/install
        $(INSTALL_DIR) \
         $(1)/usr/sbin \
diff --git a/net/bfdd/patches/010-uclibc.patch b/net/bfdd/patches/010-uclibc.patch
new file mode 100644 (file)
index 0000000..4c603ef
--- /dev/null
@@ -0,0 +1,13 @@
+diff --git a/bfd_packet.c b/bfd_packet.c
+index e8f99f9..2c9fa91 100644
+--- a/bfd_packet.c
++++ b/bfd_packet.c
+@@ -29,6 +29,8 @@
+ #define _UAPI_IPV6_H
+ #endif /* _UAPI_IPV6_H */
++#define _GNU_SOURCE
++
+ #include <linux/filter.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_packet.h>